Installation Problems Ubuntu 11.10

Installation Problems Ubuntu 11.10

I have beenusing Parallel Studio XEon Windows and am quite pleased with the installation procedure.

Installation on Linux (Ubuntu 11.10) is problematic.

In the past, on Windows, I could install for example parallel_studio_xe_2011_update2_setup.exe, before installing the original release (and/or intervening updates). An example of this is when I wipe my system and reinstall O/S, Visual Studio (updates to MS), then directly install parallel_studio_xe_2011_update2_setup.exe. This works fine.

On Linux though this seems not the case.

When installing parallel_studio_xe_2011_update2.tgz, the checking prerequisites saying missing components (32-bit Parallel Studio XE libraries) when in fact the archive contains the 32-bit libraries.

When installing parallel_studio_xe_2011_sp1_update1.tgz, the checking prerequisites saying missing components:
Intel Commposer XE 2011 Update 7 for Linux*: unsupported OS
... Inspector...
... VTune ...
when in fact the archive contains thethese components.

If I skip prerequisits, installation proceeds to an additionnal check for prerequisits, then complains about missing 32-bit libraries.

Skipping prerequisits, is proceeding now. As to if this succeeds... who knows.

Your installation script needs some work.

BTW, on the first attempt to install parallel_studio_xe_2011_sp1_update1.tgz, I did not receive an option to skip the prerequisit. The second run of the install permitted me to skip the prerequisit (then it proceeds to install that component which it was complaining about being missing).

Jim Dempsey

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I managed to get update 1 installed...

Installing update 2 now complains about missing libraries

libstdc++ (including stdc++6)

While I can locate these folders, I imagine some symbolic links are not placed where the Intel installer expects them to be.

Any pointers would be helpful.

Jim Dempsey

More information

The failing installation package was the package containing both the 32-bit and 64-bit compilers.
On Ubuntu 11.10, using Synaptic package manager I can see the 64-bit libstdc++6-4.5-dev, glibc..., and libgcc... installed.
The variants (32-bit) are not installed. When selecting to install the ...:i386 libraries, Synaptic wants to uninstall the 64-bit libraries (and compilers).

What I am trying next is to install the parallel_studio_xe_2011_sp1_update1_intel64.tgz

IOW 64-bit only.

Bummer (this means I need another HD and go through installs again).

Jim Dempsey

The above worked.

However, following the installation notes for:

Eclipse Integration

Does not work

Any assistance on this will be appreciated.

Jim Dempsey

The saga continues....
I ran into a problem with the c++debugger within Eclipse and thought I would give the Intel IDB a try...

Some comments.

The particular bug I am chasing requires me to use the disassembly window.
While this opens up ok, single stepping is a PIA. Each step in the dissassembly window (correctstep instruction icon) pulls the source window back on top of the dissassembly window, Requiring me to keep clicking on the Dissassembly window tab.

Step Into a function call crashes the debugger.

Jim Dempsey

Leave a Comment

Please sign in to add a comment. Not a member? Join today