Can't record with camera_viewer

Can't record with camera_viewer

I can use the camera_viewer sample to view the color and depth streams, however, when I add the -record -file <file name> options to save to a file, I get "Failed to locate video stream(s)". Help!

Using build 5831 on Windows 7 x64. I've tried both 32-bit and 64-bit builds with the same results.


7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Dupe. Sorry. Original thread here:

Mods, feel free to delete this thread. I tried editing my original post, but the forum failed to respond.


Hi John,

It could be you are running the file in %program files% and Windows won't give the program write access to that folder or subfolder.  Copy the exe to My Documents and try running from there.


Or put in a path e.g.  -file %homepath%\Documents\filename



Sorry for the delayed response - the forum doesn't seem to have email notifications. Or perhaps I just didn't subscribe to this thread.

Thanks for the pointers, I'll give that a try the next time I can get my hands on the camera and report back. I ended up writing my own code to write the images to disk.



I am trying to record video streaming using camera viewer sample application with -record and -file option given there

The application writing data into the specified file, I am unable to play that file,

will you please let me know is there compression or video encoding I need to use for this functionality?

or Is there any standerd encoding format I need to provide.



Leave a Comment

Please sign in to add a comment. Not a member? Join today