Depth Stream access denied, crashes apps

Depth Stream access denied, crashes apps

One of those bizarre "it worked yesterday, but it doesn't work today, and I don't know why" issues:

When attempting to run my app, which accesses the depth stream through UtilPipeline, I get an access violation:

Unhandled exception at 0x76fb15de in CreativeCam.exe: 0xC0000005: Access violation reading location 0x00000000

Further investigation indicates that any app (including pre-compiled samples from PCSDK Beta3) which uses the depth stream crashes immediately, and the "camera viewer" app says that I only have Color Streams from the Creative GestureCam.  This same camera works fine on other computers, and it worked on mine (a MacBook Pro running Win7) just last week.  Also, other Creative GestureCams which work fine on other computers exhibit the same problem on mine.  Has anyone else had this problem?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Stephen,

Sorry,  there doesn’t seem to be enough information to diagnose what’s going on.   Given the lack of responses,  it appears that it’s not a common problem.    Is it still occurring?   When it exceptions in the samples,  does it cause the same type of exception?   Can you capture the fault?    Have you tried reinstalling everything?   



You might try running a registry cleaner. If the camera runs fine on another system then it is most likely not an issue with the camera itself.

Thanks all - I ended up reinstalling the SDK and that seems to have resolved the issue.  If it crops up again, I'll gather and post more detailed information.

Leave a Comment

Please sign in to add a comment. Not a member? Join today