Softkinectic DS 325 issues

Softkinectic DS 325 issues


I am trying to work with DS 325 but for some reason it doesn't seem to work with Intel's latest perceptual SDK.

capture_viewer application doesn't seem to recognize the camera.

I am attaching the error messages i get while trying to work with it.

Could someone help me with this?

Downloadimage/jpeg 2.jpg22.08 KB
Downloadimage/png 3.png26.52 KB
5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please note that the camera is Softkinetic's DS325..

You can not check the hardware version. But you can check the camera's firmware version. Maybe you need update to latest firmware. 

I just uploaded the most recent PerC SDK and it worked fine with the DS325 - there is no need of a "firmware update".  See attached.  As Intel noted, this is not officially supported, did not go through QC, etc. so note that you are "off the reservation" and not supported by Intel, but as an FYI here is what I did to get the most recent PCSDK to work with a DS325:

1. Took off all DepthSense SDK (DSSDK) and iisu off my computer and rebooted.  If you have the SK driver on there and install the Intel SDK you are essentially installing two drivers for the camera, and there could be conflicts.

2. Installed the Intel SDK and rebooted again (as stated in the PerC SDK install instructions).

3. Launched the SDK Information Viewer to insure that the driver saw the DS325 (it did - see pic showing DS325xxxxx serial number)

4. Open the "Capture Viewer" and toggled the depth nodes and hit "Display".  Besides the DS325 it shows by built-in PC camera for 2D capture, etc. 

5. Opened PerC applications, etc. that all worked fine.

As noted if you want to use the PerC you should by an Intel/Creative camera and if you want to use the DS SDK or iisu, buy a SoftKinetic camera, and then get support from the vendor you bought the camera from.  Cross-compatibility is not guaranteed, although it will probably work with a little non-supported hacking.



Akhilesh - I have hit a problem when connecting the SoftKinetics camera to a USB 3.0 port.  Have you tried using other USB ports on your system.  It might make a difference.

Bob Davies

Leave a Comment

Please sign in to add a comment. Not a member? Join today