Voice recognition not working any more in Unity

Voice recognition not working any more in Unity


Voice Recognition was sometimes working, sometimes not, but now it never works. Initialization is ok but QueryVoiceRecognized always return false. I checked the FPS and it is around 30 (so not too slow).

I rollbacked my software to a version that was previously working (using a git repository...), but it doesn't work neither.

I tried to comment all that was gesture related (due to the recent bug in R3) but nothing seems to work.

I recently installed a new headset with a microphone so I disabled it on windows but it doesn't work neither.

I will try to reinstall the whole SDK tonight, but if it doesn't work I will be stuck.

Does anyone have any idea how to make it work again ?


12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

After reinstallation of the SDK it is working again... It seems odd though that I had to reinstall the same version of the SDK to make it work again.

I still have one problem (but it was also the case before) : even in very calm environment, sometimes, the voice recognition mode have difficulties to understand what the user is saying (I must repeat 2-3 times the same words to be understood). Some words are very simple though (as "play"). Any idea on where this is coming from ?


If you only want to recognize few words, you can try to use command&control mode instead of dictation mode. 

My problem is on Command & Control mode. I don't use dictation since I use not very common word. What is strange is that sometimes it is working 90 % of the time, but sometimes 20 %, on similar environment conditions... I noticed that very often, the return is SPEECH_UNRECOGNIZABLE or VOLUME_HIGH.

VOLUME_HIGH seems odd to me, because I don't scream on my camera, and when I record and ear myself again, it seems very fine and even a little bit low. I tried to ajust the micro volume but it made it worse.

It returns me SPEECH_UNRECOGNIZABLE regularly even when I don't speak. But maybe this is normal.

Could any device configuration trigger these problems ?


Does the voice recognition currently work or not? In your first post, you told me the voice recognition did not work any more after you updated to R3 and latest post told me it works 90% of the time. Could you provide the detail info? Please also provide the SDK_INFO(advanced mode) to me. Thanks, David

I dont Know, you gyes are talking about Vocie Recognition not working when Gesture Camera is enabled, while in my case it works fine on Release 3 , i initiated them in 2 seperate threads, so did not had any problem with Release 3 of SDK, but Release 2 is giving problem initializing the Voice Commands

@David: I am working with Unity 4.2.0f4. After having reinstalled the sdk it works, except there is a strange behaviour : after several attemps, I found out that until about the first 30 minutes after windows startup, the camera doesn't understand anything (I start and restart my program very often, so it is not linked to the state of the program). After there is about a 90% success rate, which is very correct.

Enclosed is the sdk_info.TXT.

@Omar: No I did not start them on different thread, but I am using Unity. Did you start different threads on Unity ? In fact, this doesn't solve my problem since I tried to only use Voice recognition without any improvement...


Just happened again... Voice recognition stopped working when I was running my program (it was working fine, until it suddenly stopped detecting voice, without prevent the program to run). Now it doesn't work no matter what I do. And it doesn't work on other programs too. I created a youtube video demonstrating that the voice_recognition sample program doesn't work on any settings:


Same as before, initialization works, but QueryVoiceRecognized returns false no matter which words are said, and which mode I am on (dictation or command).

Any idea what could cause this ? Is there any way to reset the sdk without reinstalling it ?

No changes was detected on the sdk_info.txt file since it worked.

Enclosed is also my Voice processing script on Unity... Maybe I am doing something bad...



Downloadtext/plain voice.txt2.22 KB
Downloadtext/plain sdk-info-after.txt44.85 KB

@sdrdis - Your video seems to be gone.  Did you ever solve the problem?

Also, see my recent reply at the bottom of this similar thread since I am now having a similar problem:


-- roschler

@Robert Oschler : are you sure the video is gone ? I can see it and can see it even if I am not logged in.

I upgraded to R4 and the problem was gone...



I can see it now.  Yesterday, it said "an error occurred" in the video player window and kept saying that even if I reloaded the page.

Note, your problem appears to be different than mine.  You are not getting any status messages at all.  I get status messages, always SPEECH_UNRECOGNIZABLE errors, but never any recognized text back anymore on Windows 8.  On Windows 7, everything works fine with the very same camera.

-- roschler

I am on windows 8 and don't have any problem. When I got this message either:

  • I did not set the microphone volume properly
  • If you connect an external microphone, might it listen to it instead of the camera ? I had this impression when I connected a headset on my computer, but I am not sure
  • If you are on command mode, be aware that some words are never recognized under certain conditions. When I moved from R3 to R4, some words were not understood anymore. And when I changed my computer location, it was much more difficult to recognize some words...
  • I found later that it is finally possible to use thread on Unity (in case you are using it). Take a look at the sample in Intel's folder. I am under the impression it improved the success rate.

Leave a Comment

Please sign in to add a comment. Not a member? Join today