Errors when using new SDK with older code and camera

Errors when using new SDK with older code and camera

Hi,

I have a executable that used to work under an older SDK (probably Beta 3) and a older camera with firmware 2028.

I've had to install this on a newer PC and I'm now getting these error message continuously with the latest SDK:

~[00001010]: Streaming Exception: tjDecompressHeader2(): Not a JPEG file: starts with 0xda 0xfd

~[00001010]: Got exception: tjDecompressHeader2(): Not a JPEG file: starts with 0xda 0xfd

~[00001010]: Streaming Exception: tjDecompressHeader2(): Not a JPEG file: starts with 0x3a 0x9b

~[00001010]: Got exception: tjDecompressHeader2(): Not a JPEG file: starts with 0x3a 0x9b

Does anyone know what would help?

Is there a self-contained version of Beta 3 or other SDKs so I can check that? The older web installer I have for beta 3 fails.

Thanks,

Pascal.

 

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

There are lots changes since Beta 3. Please recompile your code under latest PerC SDK and see if you have such issue.

Hi David,

I thought as much. Unfortunately the source code for this project is missing and rewriting it will take quite a while.

I could really do with demoing this tomorrow so is it possible to get a beta 3 full installer in the meantime?? I was using the face recognition, video and depth streams.

Thanks,
Pascal

Leave a Comment

Please sign in to add a comment. Not a member? Join today