How do I change the default installation

How do I change the default installation

I have a DVD to install the Intel Fortran Compiler for Linux*OX-Version 11on a CENTOS system--I would like to change the default directory to be something different from /opt/intel like /opt/local/intel--It never asks me if I want to change the installation directory and when I give it the installation serial number, it gives an error--"Installation can not create a
license folder. I am running this as root and the way we have the /opt mounted so that even root has permission to
create /opt/intel/licenses directory--I can change so we could make a /opt/intel but I would prefer to select a different
location such as /opt/local/intel/ for the licenses and other directories to be installed--Is there a way to do this?

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Yes you can.

First, create the directory /opt/local/intel/licenses with write permissions for root and read for others:

mkdir -p /opt/local/intel/licenses
chmod -R 744 /opt/local/intel

If you have your license file, copy it into that dir - make sure users have read access.

If you don't have your license file:
go to https://registrationcenter.intel.com, and log in. Once you login you will see your product(s). Click on "Intel Fortran Compiler Professional Edition for Linux*" link. this takes you to a page that will show your serial number , Licenses, Purchase/renewal table. Click the link "Manage" under "Licenses" There is a link to Resend license file to my email. copy to that licenses directory you created.

Now, during installation startup, DON'T enter the serial number, instead select the option to provide a path to the license file. Point it to the /opt/local/intel/licenses/.lic file.

Next, choose 'Custom' for installation

during the Custom installation, you can choose which packages to install, select them all. Next you can set up a non-default install directory. Choose that option and enter /opt/local/intel

that should do it.

ron

Ron,
Thanks so much for the help--That is what I needed--Only problem is in getting the license file for it--I did not purchase
the Itel Fortran Product--It was done by one of our Admin through another vender so when I tried to obtain the license
file going to https://registrationcenter.intel.com, it doesn't seem to work for me since I didn't purchase it. I am the
software engineer who has the job to install it--I have the DVD and serial number but I believe that is probably not
enough to get the license emailed to me--Will have to check with our admin and see who purchased the product.
Again thanks for the help.

Vic

If no one has beat you to the registration, you can register the serial number yourself at that site, which creates an account for you. For more difficult licensing problems, please use the separate forum section on licensing.

My Admin had registered the license for Fortran compiler--He has downloaded the various tar files . We have a mixture of
32 and 64 systems that might be using the compiler. I gather that the IA-32Intel64 product should work for both the 32 and
64 LINUX systems we have here. My Admin also downloaded the License file that goes with the serial number issued.
I tried installing the compiler off the DVD that I have that has the correct serial number for. I created a /opt/local/intel/licenses directory and put the license file into that directory that was downloaded. When I did the install, I gave the full name for where the license file was located which was "/opt/local/intel/licenses/COM_L_CMP_FOR_xxxx_xxxxxxxx.lic" when it asked during the installation process and it gave me "Invalid license" so I exited--My next step was to try and use one the tar IA-32Intel64 product file and try doing the installation using it and give it the serial number provided.
I checked the downloaded license file and it looked like a text file that I would have expected but seems to be invalid.
Anyhow this is where I am at

I'm going to move this to our licensing forum where the licensing experts will help you.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today