INTEL vendor daemon shutting itself off

INTEL vendor daemon shutting itself off

Hello,
I have just installed the Intel Composer XE suite with a floating license. Along with it, of course I installed the flexlm package. I believe I have set it up according to the directions, but I am having difficulties. When I initially start the license server with

`pwd`/lmgrd.intel -c `pwd`/server.lic -l `pwd`/lmgrd.intel.log

Both the vendor and license daemon start, as can be tested with lmstat or by running ps -e and looking for the processes lmgrd.intel and INTEL. The output for lmstat -c server.lic is initially

lmstat - Copyright (c) 1989-2004 by Macrovision Corporation. All rights reserved.
Flexible License Manager status on Mon 12/12/2011 13:18

License server status: 28518@levinegroup.chemistry.msu.edu
License file(s) on levinegroup.chemistry.msu.edu: /opt/intel/flexlm/server.lic:

levinegroup.chemistry.msu.edu: license server UP (MASTER) v9.2

Vendor daemon status (on levinegroup.chemistry.msu.edu):

INTEL: UP v9.2

Unfortunately, icc and ifort do not run citing (in the case of icc):

Error: A license for CCompL is not available (-92,147).

License file(s) used were (in this order):
1. Trusted Storage
** 2. /opt/intel/composer_xe_2011_sp1.7.256/Licenses/COM_L_CMP__XXXXXXXX.lic
** 3. /home/levine/intel/licenses
** 4. /opt/intel/licenses/COM_L_CMP__XXXXXXXX.lic
** 5. /opt/intel/licenses/l_XXXXXXXXX.lic
** 6. /Users/Shared/Library/Application Support/Intel/Licenses
** 7. /opt/intel/composer_xe_2011_sp1.7.256/bin/ia32/*.lic

Please visit http://software.intel.com/sites/support/ if you require technical assistance.

icc: error #10052: could not checkout FLEXlm license

However, after some period of time, the INTEL daemon turns itself off, and lmstat reports the same except that the last line changes to:

INTEL: The desired vendor daemon is down (-97,121)

ps -e confirms that INTEL is no longer running. Running icc at this point gives the same error message as when INTEL was running.

At one point, I ran lmstat and saw the following message:

INTEL: Cannot read data from license server

which seemed to occur right before INTEL shut itself off.

For what it is worth, I am already running an instance of lmgrd for the PGI compiler, which is already installed successfully on my machine a few days ago. I am not sure if this might be related.

I am not sure what is wrong. I appreciate any help anyone can offer.

Thanks,
Ben

note: edited to remove license numbers

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.