Download product

Download product


I have just purchased the following product:

Intel® Software Development Suite Student Edition [Academic - Licence With Support (1-Year) (Single User) - ESD Linux]

When I am at the download page, I have 2 options for downloading.

Intel Cluster Studio for Linux and Intel Parallel Studio for Linux.

I want to install the product on my desktop pc I can download both?

Thank you very much for your help.

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Konstantinos,

Yes, you can download both.  Please see product landing pages below, if you were interested in what features/components are included in Intel Cluster Studio XE and Intel Parallel Studio XE.  Hope this helps.

IPS XE landing page

ICS XE landing page

Thank you.
Feilong H.
Intel Developer Support

Tools Knowledge Base:

Hi Feilong,

Thank you for your response.

I am actually worried that if I download ICS, if I can use it to compile and run fortran programs on my laptop or I can to use it only to a cluster.

Thank you again!

Hi Konstantinos,

No problem.  ICS XE includes Intel compilers, which can compile your code for your desktop & laptop.  Since you don't have a cluster, I'd suggest you to download IPS XE instead, because of its smaller size.


Hi Feilong,

I am trying to install the ICS finally and I am receiving the following message:

There are one or more critical unresolved issues which prevent the installation
from continuing.  You can fix them without exiting from the installation and
re-check. Or you can quit from the installation, fix them and run the
installation again.
Missing critical pre-requisite
-- Intel(R) Composer XE 2013 Update 1 for Linux*: missing system commands

And more detailed gives me:

The following required for installation commands are missing:

Thank you!

Ok I think I solved it with this command :

sudo apt-get install g++

But after that,I rechecked the Pre-requisite and kow i get this message:

Step no: 5 of 7 | Options > Missing Optional Pre-requisite
Product may fail to collect analysis data on this system.
Ptrace is only allowed directly from a parent to a child process, or as the root
To work around this problem for the current session, use the command
    echo 0 | tee /proc/sys/kernel/yama/ptrace_scope
to set /proc/sys/kernel/yama/ptrace_scope sysctl to 0.
To make this change permanent (NOT RECOMMENDED: LEAVES HOLES IN SYSTEM
PROTECTION), set kernel.yama.ptrace_scope value to 0 in the
/etc/sysctl.d/10-ptrace.conf file under root account, then reboot the machine.

Hi Konstantinos,

Now it looks that you need to follow the instructions in that message.  Then you should be able to move forward.


Hi Feilong,

Sorry to bother you again..

But I am keep receiving missing pre-requisites messages.

This one is the last..

There are one or more optional unresolved issues. It is highly recommended to
resolve them all before you continue the installation. You can fix them without
exiting from the installation and re-check. Or you can quit from the
installation, fix them and run the installation again.
Missing optional pre-requisites
-- Intel(R) VTune(TM) Amplifier XE 2013 Update 2: Power analysis is not enabled
-- Intel(R) Composer XE 2013 Update 1 for Linux*: 32-bit libraries not found

1) for the first one, my kernel is 3.2.0-39 so probably I can't use VTune Amplifier XE 2013

2) As far for the second error, althought I installed all the 32-bit libraries it still gives me this error...

More specifically

One or more of these libraries
could not be found:
    libstdc++ (including libstdc++6)

I allready did this

sudo apt-get install ia32-libs

Any ideas?

Thank you very much!

Missing 32-bit libraries errors solved thanks to this post:

Any suggestions for the first error about Power Analysis?


Hi Konstantinos,

Regarding the Power Analysis problem, please submit an issue in VTune forum.


Leave a Comment

Please sign in to add a comment. Not a member? Join today