Doubt with counted licenses in FlexLM server

Doubt with counted licenses in FlexLM server

Hello,

I have configured and installed a FlexLM server in a Debian 5.0 32bits.

After all, if I run "/opt/flexlm/lmstat -a -c /opt/flexlm/server.lic" I get this:

lmstat - Copyright (c) 1989-2012 Flexera Software LLC. All Rights Reserved.
Flexible License Manager status on Wed 6/26/2013 15:48

License server status: 28518@MY_SERVER

License file(s) on MY_SERVER: /opt/flexlm/server.lic:

MY_SERVER: license server UP (MASTER) v11.11

Vendor daemon status (on MY_SERVER):

INTEL: UP v11.11
Feature usage info:

Users of IC2494C65: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of AdvXEl: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of ArBBL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of CCompL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of DbgL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of FCompL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of IClsTktL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of ITrAnlL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of ITrAnlW: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of ITrColL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of MKernL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of MPass: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of MPassL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of PerfAnl: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of PerfPrimL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of StaticAnlL: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of ThreadAnlGui: (Total of 25 licenses issued; Total of 0 licenses in use)

Users of ThreadBB: (Total of 25 licenses issued; Total of 0 licenses in use)

When I run some gui tool in client side, like advixe-gui, inspxe-gui or amplxe-gui, I can see in Help->About...->Details that client has received a license because lines "License type" and "Expiration date" contains correct values (they are not null), but however, if now I run "/opt/flexlm/lmstat -a -c /opt/flexlm/server.lic" in server again, system returns the same as above: Total of 25 licenses issued and Total of 0 licenses in use.

So, should I get a message when executing "lmstat" saying something like "Total of 1 licenses in use" during the execution of a graphical tool or just when executing "icc" or another command-line tool?

Thanks.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Dear Antonio,

The license is checked out only in case you are using the component. It means that for compiler it is checked out only during the compilation time. For Amplifier - during the analysis. Please refer to this article for more details: http://software.intel.com/en-us/articles/when-is-a-floating-license-seat-checked-out-and-checked-in

Regards,

Igor

Leave a Comment

Please sign in to add a comment. Not a member? Join today