Installation of Intel Parallel Studio XE on Debian 7

Installation of Intel Parallel Studio XE on Debian 7

I am trying to install Intel Parallel Studio XE 2013 SP1 on Debian 7.3. However, prerequisites check reports unsupported OS.

Why is that?

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi, Leos

Debian 7.3 is just released this month. The latest Intel(R) Parallel Studio XE 2013 SP1 was released in October, when Debian 7.3 is unavailable and not tested yet.

Please keep use old Debian 7.2 for now.

Hope this explains.

Thank you.
Yolanda Chen
Intel Developer Support

Tools Knowledge Base:

Thank you. I installed debian 7.2 with the very same result. So what to do now?


Hi, Leos

I'm sorry. Have you tried Debian 7.1 then?

I noticed that Debian 7.2 was released on Octobor 12th, close to the date when Intel(R) Parallel Studio XE 2013 SP1 update 1 was released on Oct 18th. It is possible that Debian 7.2 was also not tested in this release.

Anyway  I think our release notes should be more clear about this, I will escalate the problem. Thank you for raising the issue.

Thank you.


I have just tried Debian 7.1 Exactly the same result. But I noticed an error when rechecking prerequisites:

sh: 1: /tmp/install.EVjT8R/python_check/ Syntax error: "(" unexpected

Any ideas?

I managed to get dvd with debian 7.0. This time the prerequisites are satisfied. It seems that parallel studio only supports debian 7.0 which is really bad because it is no longer supported and even obtaining this version is very difficult. More, given the fact that 7.3 is just a point release, parallel studio should support it even if it was released after the parallel studio SP1 itself.

Will Intel do something about that? Thanks.

I don't think the version of Deb is the problem.

You should be able to use 7.3, although you will get a warning that it's an unsupported OS.  If you continue it should install BUT

YOU MUST INSTALL PREREQUISITE packages AND you need to point /bin/sh to /bin/bash and not dash!

Read this:

Yes, it is referring to older Ubuntu and Debians but the same problems exist in current versions.  Just follow it and see if that helps.

One other last note:  VTune is going to be a problem.  The collection driver is specific to an OS version.   That may limit you to whatever the Release Notes document says is supported.  The compilers and other tools are not so particular to OS versions, they don't care.  But VTune drivers have to be built for specific versions UNLESS you install without the collection driver and build your own from sources.


Thank you Ron for correcting me.

If Debian 7.3 can be supported, that would be great.

Leo, please follow Ron's instructions and see if it works for you with Debian 7.3.

Sorry for any inconvenience.

Thank you.



Leave a Comment

Please sign in to add a comment. Not a member? Join today