Help:installing SGX PSW 1.9 on Ubuntu 16.04 64bits error

Help:installing SGX PSW 1.9 on Ubuntu 16.04 64bits error

Hello,

When i installed SGX PSW 1.9 on Ubuntu 16.06 64bits, it showed that

 "x86 Intel SGX PSW Package can not be installed on x86_64 platform"

I wonder how to solve the problem...

Thanks!!!!

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

did you build your own installer or downloaded from somewhere? For latter case, could you give the URL where you downloaded?

Official release (https://download.01.org/intel-sgx/linux-1.9/sgx_linux_ubuntu16.04.1_x64_...) only supports x86_64.

Quote:

Haitao Huang (Intel) wrote:

did you build your own installer or downloaded from somewhere? For latter case, could you give the URL where you downloaded?

Official release (https://download.01.org/intel-sgx/linux-1.9/sgx_linux_ubuntu16.04.1_x64_...) only supports x86_64.

Hello

Thank u for your response.

I downloaded the SGX SDK master from http://github.com/o1org/linux-sgx  

$make sdk_install_pkg

the result is"Generated sdk installer:./linux/installer/bin/sgx_linux_x86_sdk_1.9.100.39124.bin"

And then I used the sgx_linux_ubuntu16.04.1_x64_psw_1.9.100.39124 and sgx_linux_ubuntu16.04.1_x64_psw_1.9.100.39124 in place of the x86sdk and x86psw. Both of them are successfully installed.

 

 

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today