How to uninstall Intel System Studio 2019

How to uninstall Intel System Studio 2019

Hi,

I installed the Intel system studio 2019 (GUI ver) in my local (Ubuntu 16.04).

For testing, I tried to install the Intel system studio (CLI ver). However the install.sh script prints the log as below.

WARNING: Destination directory already exists.

--------------------------------------------------------------------------------
The selected tools are already installed and cannot be reinstalled into the same
target directory.
To uninstall or reinstall you must first deselect all tools and let the
installer finish; then restart the installer.
If you are attempting to add new tools to an existing installation, check at
least one new tool from the list.
If none of the above apply, restart the installer and choose a new directory for
installation using the installer's customization screen.
--------------------------------------------------------------------------------

So, I want to uninstall the Intel system studio (GUI ver) from my local.

The GUI ver have no the uninstall.sh script.

 

Please answer the how to uninstall the program.

Thanks for any pointers to resolving this.

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

The correct way to uninstall Intel System Studio 2019 in Linux is to navigate to the installation path of Intel System Studio 2019.

By default the product should be installed under /opt/intel/ until unless you have specified a custom path for installation.

Launch the ./install.sh script and if any components of Intel System Studio 2019 is installed it will prompt you to modify or uninstall the product.

Thanks you!!

Until before see the your answer, I checked the install script downloaded from web instead of the install script on the /opt/intel/.

I solved the issue by the your answer.

 

Unfortunately I find the CLI mode installation the Intel System studio CLI version.

Because I need the CLI version to install it on the linux server.

So, is it provides the CLI version?

 

Anyway, Thanks you for your help again.

Yes, Intel System Studio 2019 does support the CLI installation version for Linux.

Refer to the installation README

https://software.intel.com/en-us/intel-system-studio-readme#inpage-nav-5-3

 

 

I have same problem with @kwak, and I tried to launch the /opt/intel/install.sh script. But it's not worked, and nothing is happened.

How can I uninstall Intel Studio 2019 completely with cli mode?

@liu, jiaxin

In the silent.cfg file, here exits a field "PSET_MODE". Modifying it to "PSET_MODE=uninstall". And in the command line, run "./install.sh -s silent.cfg", then it's done!

Leave a Comment

Please sign in to add a comment. Not a member? Join today