TBB on Windows7 x64 and VisualStudio2010 , failure LINK2019

TBB on Windows7 x64 and VisualStudio2010 , failure LINK2019

Hi.

I have some troubles now, so could I know how to resolve them?

OS:
Windows7 Ultimate x64 on Hyper-V

4 Core(all cores) is assigned

Tools:
Visual Studio 2010 Premium (evaluation)

Environment:

INCLUDE=C:\\tbb\\bin\\..\\include;
LIB=C:\\tbb\\bin\\..\\lib\\intel64\\vc10;
TBB30_BIN_DIR=C:\\tbb\\bin\\
TBB30_INSTALL_DIR=C:\\tbb\\bin\\..
TBB_ARCH_PLATFORM=intel64\\vc10
TBB_TARGET_ARCH=intel64
TBB_TARGET_VS=vc10

IsetLIBPATH and INCLUDEPATH, /MD in C++ Compiler Option.

Now, I success compiling but failure on linker.

1>TBB_Sample6.obj : error LNK2019: unresolved external symbol "private: void __thiscall tbb::mutex::internal_construct(void)" (?internal_construct@mutex@tbb@@AAEXXZ) referenced in function "public: __thiscall tbb::mutex::mutex(void)" (??0mutex@tbb@@QAE@XZ)

(It's one of all, transfer Japanse to English)

I think that I have same errors in (#6 Reply To #5) on

http://software.intel.com/en-us/forums/showthread.php?t=57017

What should I do?

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I resolved this errors.

I need to set Configulation Manager Win32to X64, Win32 as default.

But I can't change this setting Win32 to X64 on Visual Studio 2010 Express at first.
So, I give up to change on Visual Studio 2010 Premium :-(

Thanks.

Leave a Comment

Please sign in to add a comment. Not a member? Join today