DLL not found exception when TBB is used

DLL not found exception when TBB is used

Hi,
I have few image processing application written in C++, which are exposed by a dll and called by a .Net application.

The application works fine if I write thecode in serial fashion in the dll. But, when I used TBB, I got error from the C# Visual Studio saying DLL not found. Below is some details about the exception:-

System.DllNotFoundException was unhandled
Message="Unable to load DLL 'C:\\****.dll ': The specified module could not be found. (Exception from HRESULT: 0x8007007E)"

I have tested my settings for TBB, by executing another application as desired.

Though most of the code is in C#, since TBB is the difference, I will like to know, if some one else also has found such issue ? Any susggestions ?

Thanks.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Quoting - kumarbhargav
Hi,
I have few image processing application written in C++, which are exposed by a dll and called by a .Net application.

The application works fine if I write thecode in serial fashion in the dll. But, when I used TBB, I got error from the C# Visual Studio saying DLL not found. Below is some details about the exception:-

System.DllNotFoundException was unhandled
Message="Unable to load DLL 'C:\****.dll ': The specified module could not be found. (Exception from HRESULT: 0x8007007E)"

I have tested my settings for TBB, by executing another application as desired.

Though most of the code is in C#, since TBB is the difference, I will like to know, if some one else also has found such issue ? Any susggestions ?

Thanks.

It got solved, but I am sharing my thoughts, if it could be helpful for others.

This is not a problem with TBB, this is basically a problem with any native dll.
More on this can be found here:-
http://forums.asp.net/p/939729/2093799.aspx
It got solved for me, once I copied tbb_debug.dll to my dll folder.

Earlier the dependency walker was giving error:-
"Error: At least one required implicit or forwarded dependency was not found." It was mentioning to tbb_debug.dll.
Once I copied to my dll folder, this error was gone and tbb_debug.dll was showing in the dependency tree.

But, again same error was coming and this time the dll MSVCP90D.dll was said to be missing.
My question is will the developer need to copy each dll on which it's dependent in the tree ? Although my app is working, but I doubt I am fully using the dll. Will I get errors in case tbb needs to call those dlls on which it's dependent ?

Does anyone has a better solution than copy ? Adding the location in path also solves this, but again this has to be done for all dlls in thetree.

Leave a Comment

Please sign in to add a comment. Not a member? Join today