Seeking and Chunked transfer protocol

Seeking and Chunked transfer protocol

Hi,

With the AV Media Server, if the chunked transfer protocol is used, position seeking doesn't work. I would like to correct this problem, but I don't understand how the client send the offset value with the chunked transfer protocol (perhaps, it's not possible).
Is someone has some explanations on this ?

Cordially,Stephane.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It seems like this forum and the UPnP Developer Tools have both been abandoned but I thought I would try here anyways.  Has anyone found a way to enable seeking/duration with these tools?  I am trying to stream .ts files with appropriate Content-Length and Durations but no matter what I try my Sony Blu-ray Player does not show a file length and claims that seeking is not allowed. 

I have tried matching responses from other DLNA/UPnP servers that do show the appropriate length and allow seeking with the same files (basically adding "Accept-Ranges: bytes" to the Head sections of the responses) but still no luck.  I have tried setting "HTTPSession.CHUNK_ENABLED=false" which also doesn't work.

Leave a Comment

Please sign in to add a comment. Not a member? Join today