Error: "This is not a DEC fortran module file"

Error: "This is not a DEC fortran module file"

I am running CVF 6.6B on windows XP and am getting a compilation error as follows: : Error: This is not a DEC Fortran module file. [PLAT]
USE sensor, ONLY : sensor_name

The compiler is complaining about sensor.f90.

I have tried cleaning and rebuilding, but still get the same error.

I have also found that some projects fail to find modules that are clearly in the right spot. I have even given absolute path names in the project settings but that doesn't seem to make any difference. So while a I have a specific error as indicated above, I have also experienced other problems and theefore have a general question about any known problems regarding the use of CVF with XP and any special configurations that might be required for installation, etc... Read below for a little more background.

A little background:

I am running CVF 6.6B on windows XP and have had several problems getting things to compile and run without crashing. Everything was fine on Windows 2000, but when I switched to XP I experienced some strange run time crashes (debugging did not provide any clues - it was like some part of memory was corrupted). After numerous installation iterations I have found that the upgrade to 6.6A seems to be the root of the problem. When I use 6.6B I am able to build and run some applications but am not able to compile all my projects.


6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It's not complaining about sensor.f90, but about sensor.mod - the compiled module file that would result from sensor.f90 being compiled.

The first thing I suggest you do is Build..Rebuild All. But the other symptoms suggest that you have something wrong on your PC - perhaps disk structure corruption or a bad video driver. What I usually suggest in cases such as this is to run SCANDISK on your disk, and if it doesn't report problems, boot in Safe Mode and try the build again. This will help eliminate possible culprits.

I doubt that the 6.6A update itself caused the problem, but if your PC has other issues, anything that writes files could be in trouble.


Retired 12/31/2016

Thanks for the suggestions.

I tried rebuilding after running SCANDISK, and also tried rebuilding while in SafeMode. In both cases I got the same compile error (that sensor.mod is not a DEC fortran module file).

I should probably give a little more background on this:

My workspace has two projects that depend on a common library (common.lib). My "common" project contains sensor.f90.

Project A (which has several USE statements for sensor) has no problem compiling and running.

Project B, however, will not compile and gives the error I indicated above.

We have no problems compiling and running both projects on other systems running Windows 2000.

Ever since I loaded XP I have had all kinds of problems (either trying to compile or run various projects) using CVF and Visual Studio 6.0. I have installed and uninstalled many times. In the process of these installs I have done several system restores and fixed registry entries with "Registry First Aid in an effort to "clean" my system. I am very hesitant at this point to re-intall Fortran or Visual Studio because I do have some functionality now, whereas previous installs resulted in no capability (e.g., strange runtime crashes). As you say, the problem may not be related to 6.6a, but all I can tell you is that I have installed CVF (w/ Array Visualizer)and Visual Studio numerous times and have had a range of problems (including compiling and runtime crashes). At times I would try to vary the install configuration to see if there was a specific product/component or option that was causing the problem.

The version I am using is Visual Studio 6.0, Enterprise Edition (dated January 2001) from a single DVD.

Any other trouble shooting ideas?

Note: I also tried the Intel fortran 7.0 compiler with VS.NET, but found that these two products did not seem very well integrated. I also had many compilation problems - mostly centered around module dependencies - as though the compiler didn't compile in the right order which resulted in numerous complaints about modules not being found. Also found out that mixed languages within a project are not allowed. Based on all that I decided to go back and try and make CVF work with VS6.0.

I guess anothe roption would be to try Intel fortran with VS 6.0. Any experience with that?



I'm almost sure I got this error a few weeks ago with CVF 6.6B on W2K. Before doing a rebuild all, I deleted the offending .mod and trashed it.

Gerry T.

> I'm almost sure I got this error a few weeks ago with
> CVF 6.6B on W2K. Before doing a rebuild all, I
> deleted the offending .mod and trashed it.
I just remembered, in the use statement, the only option was implicated in the error (how precisely, who knows) so I eliminated it. The sole reason this sticks in my mind was that it was identified as a DEC error, and not a MS, Compaq, or Intel error; I'm a sucker for nostalgia.

I use CVF 6.6 on Windows XP many times daily, and there is no problem. We also see no pattern of complaints from users with this combination. The best suggestion I have to offer is that if installing XP created problems, there is some issue with a driver or other aspect of your installation that is interfering with CVF. I usually suggest that people who have problems of this nature try booting into Safe Mode and see if the problem remains.

If you are getting {"not a valid DEC Fortran module file"), please ZIP up your project, along with the .mod files (and sources) in question and send us a problem report at I have yet to see a case of this error being given that wasn't valid (the .mod being opened was not generated by CVF.)

I do not recommend the combination of Intel Fortran 7 and Visual Studio 6. If you don't like what you see with VS.NET, you'll like that combination even less.


Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today