More XP problems

More XP problems

I am finding more problems with CVF and XP. I am trying to go back to default real*8. This shows up in the compilation options window as "real_size:64". When examining reals in debug mode, they are all single precision except for ones that I have explictly declared as real*8. I've tried deleting all the modules, object files, and executable from the debug directory, but a new compile still ignores the "real_size:64" option. Any thoughts on how to get this to work again? I'm now wondering what other options are being ignored.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

An update. Under Windows 2000, whenever I changed any compilation options and then tried to run the program, CVF would state that the project settings had changed and would I like to rebuild the project. That no longer occurs under XP. Also, when a program was being compiled, the "Dependencies", "Settings", and "Export Makefile" would be greyed out. Under XP they are not, but clicking on them does not bring up the dialogue box. This last one is trivial, but it really makes me wonder what other problems are associated with CVF and XP. Be careful upgrading to XP if you depend heavily on CVF.

Regarding the default size of a real, is it possible that you have more than one compilation option that affects this attribute? Anyhow I just tried compiling with /real_size:64 under XP and it works as expected.


I don't think there are any other compilation options that affect the size of reals. However, I went back to the defaults that were set under my original workspace which includes the real_size:64 option and I still can't get double precision when I compile the code.

Leave a Comment

Please sign in to add a comment. Not a member? Join today