ActiveX (ComDlg32.ocx)

ActiveX (ComDlg32.ocx)

I call the CommonDialog Control from VF after having created the COM interfaces with the module Wizard.
All runs perfectly with the CommonDialog methods ShowColor, ShowPrinter and AboutBox. But Calling the methods ShowOpen and ShowSave has no effect: the program run over the call without any noticeable effect.
Can anybody help?
Leonardo Presciuttini, Italy

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The problem in the first message is due to some malfunction in W2000.
1)The executable runs properly on another laptop with W98
2)Under debug, the code in comdlg32.ocx calls NTDLL.DLL in order to manage the heap, and encounters a INT 3 instruction built in NTDLL. Resuming execution produces after a while block of execution (see also Before and after interrupt I get the following messages (in Visual Studio) respectively:
HEAP[Xfoil.exe]: Heap block at 0014CEB8 modified at 0014CEC0 past requested size of 0
HEAP[Xfoil.exe]: Invalid Address specified to RtlFreeHeap( 130000, 14cec0 ) (I got other references to freeing twice a heap allocation and producing this way that error)
3)What happens is similar, but not identical to what described in Q305227
4)Much similar is what described in
5) I have W2000 SP3 + several hotfixes. Tried to unistall SP3 with no effect. Reinstalled SP3. Seems that a bug in NTDLL.DLL claimed to be solved in SP3 by MicroSoft, is not yet fixed.

I agree that this seems a very solid problem. Nevertheless can anybody help?


Leave a Comment

Please sign in to add a comment. Not a member? Join today