$line directives unsupported in CVF6.6? Any replacement?

$line directives unsupported in CVF6.6? Any replacement?

Today i upgraded from CVF6.5 to 6.6 and have stumbled across the fact that the $line directives seem to be not supported any more? I was wondering if there was any replacement or something else i could use....

We use our own inhouse written FPP which is why we need to use them. It does lots that the CVF fpp does not do at this stage


7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

$line? I never heard of this. Do you perhaps mean #line?

Steve - Intel Developer Support

From the CVF6.6 Release notes....

"The following features from Microsoft Fortran PowerStation are not
supported by Visual Fortran:
* Listing metacommands - $page, $pagesize, $linesize, $[no]list,
$include, $line"

They worked in 6.5

Can i perhaps use #line instead?

I don't know what $line did, and would be astonished if it actually worked - I'm sure we didn't remove support for it. Maybe #line will work for you - that's a CPP-style directive.

Steve - Intel Developer Support

$line did in CVF6.5 exactly what the #line CPP directive does - i.e to setup the correct line numbers in the source when you INCLUDE files (like common blocks) so that debugging works. It definately, positively *used* to work :-)

I tried #line and the f90 compiler complains about that directive so my guess is doesnt support it.

Anyway i am going to try a few more things. Thanks for you responses.


Curious. I'm travelling this week so can't try it out, but I'll look into it when I get back next week.

Steve - Intel Developer Support


Can you expand on your comment about $line setting up the "correct" line numbers for INCLUDEd source files so that debugging "works"? What happens when you don't use $line?

Mike D.

Message Edited by durisinm on 03-31-2004 04:49 AM

Leave a Comment

Please sign in to add a comment. Not a member? Join today