Visual Fortran DFDEV.EXE application error

Visual Fortran DFDEV.EXE application error

When I attempt to "add files" to a project in developer studio, I get a dfdev.exe application error: cannot instruction xxxx at memory nnnn.
I've used this program for years with no trouble. I have the latest V6.6C. I suspect an incompatibility with one of the more recent Windows 2000 patches.

I erased all .OPT files
Removed the two suggested registry Keys
Uninstalled and reinstalled Visual Fortran 3 times
No Luck.

Any ideas? HP wants $250./hour to troubleshoot. I consider this an installation problem but they still want the fee.

14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I've haven't encountered this so I'm sorry I can't help although I supsect it won't cost $250/hr to resolve as someone more in-the-know than me will come to your rescue.

Don't pay HP for anything intangible: they're trying to pay off the ~ US$100M they owe the Government of Canada for bilking taxpayers for services unrendered over the last decade in some sinister scam that the Supreme Court of Canada uncovered. Needless-to-say, they deny any impropriety just like Lord Blackhead of Crossharbour (or whatever hes calling himself pursuant to his claim for Canadian refugee status protection from creditors) at the Delaware Court of Chancery.

Good Luck,
Gerry T.

The department of HP that wanted $250/hour has never heard of CVF. The documented support channel for CVF is e-mail to vf-support@compaq.com (hp.com works too). It's free.

Do you also have MSVC6 or Visual Studio 6/'98installed? If so, download and install Visual Studio 6SP5.

Steve - Intel Developer Support

I only have CVF (Compaq Visual Fortran, latest version V6.6C). But here's an update.

When I called HP back (i.e. the original $250/hr line) they now referred me to yet another number (probably the 30th!). When I was finally able to talk to someone else, they said they wanted $295 PLUS a $500 setup fee! for a single incident (even though I consider this an installation problem).

I installed CVF on a different machine and it runs fine. I also installed it on my original machine under a different user name and it runs OK. It still does not run under my User Name. The problem is I'm on a domain network and I need CVF to run on the original machine under my user name - thus back to square 1. I wonder what to look for given this scenario.

There is no phone support for CVF.

Ok, you gave me a good clue. Exit Developer Studio. While logged on as you, Start, Run. Type REGEDIT, click OK. Click on the + signs next to the following names in order: HKEY_CURRENT_USER, Software, Microsoft, DevStudio. Click on "6.0" and press Delete. Close REGEDIT.

Now try your project again.

Steve - Intel Developer Support

No luck Steve.

Thanks

Very puzzling. If you do a search of this forum on DFDEV.EXE, you'll see that this exact problem is usually solved by the suggestion I gave you.

Try this last resort. Uninistall CVF. Delete the DevStudio registry tree under both HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. Reinstall. Run Per-User Setup.

If that doesn't fix it, I'm out of ideas.

Steve - Intel Developer Support

No luck Steve. I tried both your suggestions several times.

Guess we're both out of ideas.

Should I convert to Intel Visual Fortran? If I do, do I have to first purchase MS Visual Studio.NET or MS Visual C++.NET?

Thanks

Well, I certainly would recommend upgrading to Intel Visual Fortran. Yes, you will have to buy MSVC++.NET - the Standard Edition is the lowest cost option (street price around $80.) Some resellers will sell you a bundle of these two together. You can also choose Visual Studio.NET if you want the added products, but that's a lot more money.

Steve - Intel Developer Support

Not that I'm adding anything smart about it, but out of curiosity...

Does it crash on every project or just that particular one?

Jugoslav

Jugoslav
www.xeffort.com

CVF crashes in upon itself. No other apps are affected. No other apps crash.

What Jugoslav was asking isdoes this happen on only a particular project, or does it happen for any project, even a newly created one?

It is MS Developer Studio that is crashing, not that that is any solace to you.

Steve - Intel Developer Support

Hmm i think i have in this situation before..

Its because SP5 of the Visual Studio. I re_format, install just Fortran. If you need Visual C++ or Visual Studio Stuff in same computer it can be very messy.

I do not have MS Visual Studio or MS C++. I only have MS Developer with my CVF.

Developer fails for any project - old or new. I even erased all my projects to no avail.

Leave a Comment

Please sign in to add a comment. Not a member? Join today