IVF and Winteracter

IVF and Winteracter

I have problem to get the Winteracter to run under IVF.
Somehow my settings are not complete.
I have set the path to libs and includs, but still get error messages.
Is somebody else using Winteracter together with IVF ?
Klaus

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Many are using this combination successfully. Have you contacted ISS asking for help? What sort of error messages are you seeing?

Steve - Intel Developer Support

Thanks
Yes I have contaced ISS.
They told me to read the manual and to set the necessacy paths.
Well, thats what I did as far as I could.
I have defined the following Winteracter paths in
the .net Libraries and include files :
C:wintlib.if8
C:wintinclude
The error I get is :
c:Fortran estdialog
esource.rc(11): fatal error RC1015: cannot open include file 'winparam.h'.
This means, that the 'winparam.h' ( which is located at C:wintinclude ) cannot be found.
Probably an easy problem to solve, but I am stuck.
Klaus

I think the Resource Compiler uses the Visual C++ directories. Select Tools..Options..Projects..VC++ Directories and add the path there.

Steve - Intel Developer Support

Klaus,

I use Intel Fortran and Intel C/C++ with Winteracter. My INCLUDE, LIB, PATH and WINTER environment variables are preset as follows:

INCLUDE=C:Program FilesIntelFortranCompiler80ia32include;
C:Program FilesIntelCPPCompiler80Ia32Include;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
ATLMFCINCLUDE;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
INCLUDE;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
PlatformSDKincludeprerelease;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
PlatformSDKinclude;
C:Program FilesMicrosoft Visual Studio .NET 2003SDKv1.1
include;

INTEL_LICENSE_FILE=C:Program FilesCommon FilesIntelLicenses

INTEL_SHARED=C:Program FilesCommon FilesIntelShared Files

LIB=C:Program FilesIntelFortranCompiler80ia32lib;
C:Program FilesIntelCPPCompiler80Ia32Lib;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
ATLMFCLIB;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7LIB;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
PlatformSDKlibprerelease;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7
PlatformSDKlib;
C:Program FilesMicrosoft Visual Studio .NET 2003SDKv1.1lib;

Path=C:Program FilesIntelFortranCompiler80ia32in;
C:Program FilesIntelFortranIDB80in;
C:Program FilesIntelCPPCompiler80Ia32Bin;
C:wintin;
C:Program FilesMicrosoft Visual Studio .NET 2003Common7
IDE;
C:Program FilesMicrosoft Visual Studio .NET 2003VC7BIN;
C:Program FilesMicrosoft Visual Studio .NET 2003Common7
Tools;
C:Program FilesMicrosoft Visual Studio .NET 2003Common7
Toolsinprerelease;
C:Program FilesMicrosoft Visual Studio .NET 2003Common7
Toolsin;
C:Program FilesMicrosoft Visual Studio .NET 2003SDKv1.1in;
C:WINDOWSMicrosoft.NETFrameworkv1.1.4322;

WINTER=C:wint

Maybe you can base your settings on these; you can almost certainly omit some of the above
- experiment and adapt as necessary. Hope this helps a bit,

Edmund.

Thanks for your help
I am one step further.
But now I get lots of linker errors like :
Linking...
dialog.obj : error LNK2019: Nicht aufgelstes externes Symbol '_WINITIALISE', verwiesen in Funktion '_MAIN__'
dialog.obj : error LNK2019: Nicht aufgelstes externes Symbol '_WINDOWOPEN2', verwiesen in Funktion '_MAIN__'
dialog.obj : error LNK2019: Nicht aufgelstes externes Symbol '_WDIALOGSELECT', verwiesen in Funktion '_MAIN__'
(sorry its in german)
It seems, that the linker does not find the Winteracter lib., but the compiler does find it.
Is there somewere in .NET a place were I can define linker options ?
(This .Net drives me crasy.
I am loosing the overview of what I am doing.
GOOD OLD TIMES are gone)
Klaus

Individual libraries must be specified using:

Project/Properties/Linker/Input/Additional dependencies

Alternatively, !DEC$OBJCOMMENT LIB: "Winteracter.lib" should also work.

Is thisWinteracter library for IVF 8? Your post suggests that compiler expects that Winteracter routines have IVF calling convention (cdecl+uppercase). If adding the lib above does not work, go to the directory where Winteracter.lib resides in the command prompt and type

dumpbin /symbols Winteracter.lib > C:Temp.txt

then examine Temp.txt. What does e.g. Winitialize look like: _WINITIALIZE, _WINITIALIZE@0 or something else?

(This .Net drives me crasy. I am loosing the overview of what I am doing.
GOOD OLD TIMES are gone)

Amen to that :-).

Jugoslav

Jugoslav
www.xeffort.com

Klaus,

Why not just ignore Devstudio? You can use WiDE (Winteracter Development Environment) or just compile in a "DOS Box" with makeif8.bat. Both are supplied as part of the Winteracter package. I have found that the complexity and options of Devstudio "get in the way" ofprojects. IMHO the WED text editor, the resource editor and the other toolsincluded in WiDE provide a much more user-friendly and efficientenvironment than Devstudio - for the Winteracter developer. The necessary "includes" etc. are automatic.

For Fortran development, my understanding and experience indicates that we must install Visual Studio .NET (or the Visual C/C++ subset) only so we can have access to certain libraries (e.g. user32.lib, gdi32.lib etc.) and utilities (e.g. link.exe, lib.exe etc.).

Try using WiDE or makeif8 to compile one of the Winteracter demo applications (found in various folders within c:wintdemos) to verify that your system works - thendo the samefor your own application.

HTH, Best wishes,

Edmund.

Thanks guys.
I know i can use WiDE or DOS.
I grew up using Fortran and DOS (without windows)
It was a great time !!!!
The past years I am using CVF and Winteracter and I am actually very happy with it.
Now CVF is gone (or will be gone once) and I am trying to stay 'up to date' using this .Net stuff and IVF.
In fact I will keep using CVF as long as it works.
I just want to make sure, that once CVF does not work anymore
(due to change in oparating system or XP service packs).
Therefor I am trying to build an example projekt under .NET using IVF.
But up to know no luck.
Probably it is just a wrong setting, but there are so many settings at different places that I am just lost.
All I can do now is 'trial and error' to see were the mistake is.
Using WiDE and the Winteracter demos work fine.
So the mistake is somewere in the .Net settings.
Klaus

Leave a Comment

Please sign in to add a comment. Not a member? Join today