/debug-parameters not working

/debug-parameters not working

Hello,

I have the following fortran file which I compile and link to a C++ application using Visual Studio 2003. When I check the value of HALF2 it shows 0.0. What else needs to be done to view the correct value? I am using the /debug-parameters option (see full options below).

Ian

(routine clipped to save space)

subroutine tnmenu (ipltflg,iwin,angl_in)
real HALF2
parameter (HALF2 = 0.5)

if (irot .lt. 1) then
cenx = cenx + HALF2
ceny = ceny + HALF2
end if
return
end

Compiled as:

ifort /debug-parameters out:tnmenu.obj /Zi /Od /iface:cvf /traceback /check:bounds /libs:dll /threads /c tnmenu.for

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

What is the exact version of the Fortran compiler you are using? 9.0.xxx ? To see this, look in the file C:Program FilesIntelCompilerFortran9.0DocsNotesfsupport.txt

Retired 12/31/2016

Hi,

The version listed there is W_FC_P_9.0.018

Ian

Ok - the feature did not work in that version and was noted in the release notes. Please download and install the latest version, 9.0.028, from Intel Premier Support.

Retired 12/31/2016

Should I be able to access premier support with just an evaluation license? I get an access denied message.

Ian

If you register the serial number, yes, for the duration of your evaluation license.

Retired 12/31/2016

The serial number is registered. I just sent an email to technical support.

"the latest version, 9.0.028, from Intel Premier Support
", hm, I only see 9.0.025 there? 2:00 PM Pac 12/9/2005. I'm crrent on support lic.

Ian P.

Sorry, 9.0.025 is correct.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today