Using Winteracter with IVF 9.1 and VS 2005

Using Winteracter with IVF 9.1 and VS 2005

Hi Folks.

I have a program I am moving from CVF6.6/Winteracter4.1 to IVF9.1/Winteracter 7.10g. Using CVF, I generated the resources (dialogs, menus, etc.) using the Winteracter 4.1 resource editor and then compiled them using the Visual Studio 6.0 development environment. That worked just fine and I could use all of the resource features available in Winteracter and not have to deal with WIDE (I don't like the editor, sue me).

Now, using IVF 9.1 and Winteracter 7.1 and VS 2005, when I generate a resource script using the Winteracter 7.10g resource editor and put that into my IVF 9.1 project in VS 2005, the resource script doesn't seem to be working (i.e., the .rc file is visible in my list of project files). What happens is that the program compiles and runs in that the main window opens, but neither the menu bar or the dialog that is the sub-component of the main window load.

Does anyone know if there is a trick or setting I need in VS2005 to get it to use the resource script I generated in Winteracter or will VS2005 not play nice with resource scripts generated outside of VS2005?

Thanks for any information you can provide.

-Bill Asher

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi
I use VS2005 + IVF10 + Winteracter V 7.10 and ist works fine.
You need to do some settings which are explained in the Winteracter help docu and also somewhere in this forum.
Klaus

Klaus:

I am sure it works fine if you generate the resources in VS2005 using the resource editor in VS, but do you generate the resources using the resource editor that comes with Winteracter and then try and import that into VS? It doesn't seem to me to be a "settings" issue since VS knows the resource file is there, it just won't compile it, or whatever the heck it does with the .rc file, to make it work with the fortran code.

-Bill Asher

Since I presume that Winteracter doesn't have its own resource compiler, I'd have to think the resource file was designed to be compiled by Visual Studio's. Can you open the resource file in VS and see the various resources (dialogs, etc.)? What happens if you make a minor change and save it?

Retired 12/31/2016

I had the same problem with Winteracter 7.1f (IVF 9.1, VS2005). The documentation of Winteracter says:

  • Visual Studio may not be configured to build resource files. In this case right click your resource file in the Solution Explorer and select Properties. Fill in the Command Line (rc pathfile.rc) and Outputs (pathfile.res) fields.
  • The message is a little bit cryptic. Of course you have to replace the text 'pathfile.rc' with the directory and name of your resource file. The same is valid for the output file ('pathfile.res'). After filling in theproper file name including the patheverything worked fine.

    I do not see any reason why VS should not beconfigured to build resource files. Has someone an explanation?

    Greetings, Wolf

    Hello
    Yes, this is the way I do it, as Rase wrote above.
    It works good.
    I use winteracter rescource editor externally to do the rescources.

    Klaus

    Leave a Comment

    Please sign in to add a comment. Not a member? Join today