Error 1: error_opening_IPO_object_list

Error 1: error_opening_IPO_object_list

Hello!

I just installed v10.0.27 under XPto replace my previous installation of v9.1.After running some "builds" on existing projects I always receive a linker error:

Error1 error error_opening_IPO_object_list: couldn't open multi-file optimizations object listLink

Then I tried a new project ("the Console sample"). Same error. Any idea what is going wrong?

Thank you.

Joerg Kuthe

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I would check the setting of your TEMP environment variable and make sure that it points to a place that you have write permission to. Also, did you select 10.0 under Tools > Options > Intel Fortran?

Retired 12/31/2016

>I would check the setting of your TEMP environment variable and make sure that it points to a place that you have write permission to.

I haven't changed this. Thus, this is the same TEMP variable as it has been before. Moreover, I am logged in with administrator rights.

>Also, did you select 10.0 under Tools > Options > Intel Fortran?

Yes, 10.0.27 is selected.

Now, I have uninstalledIntel Fortran completely and re-installed v10.0.27. But, at the end: same error.

To check whether the compiler works I have run both compiler and linker from the DOS prompt. Here are the results:

C:TempConsole1>ifort console1
Intel Visual Fortran Compiler for applications running on IA-32, Version 10.0
Build 20070809 Package ID: W_FC_C_10.0.027
Copyright (C) 1985-2007 Intel Corporation. All rights reserved.
ifort: command line warning #10161: unrecognized source type 'console1'; object
file assumed

ipo: error #11033: Fatal error cannot open console1
ifort: error #10014: problem during multi-file optimization compilation (code 1)

C:TempConsole1>ifort console1.f90
Intel Visual Fortran Compiler for applications running on IA-32, Version 10.0
Build 20070809 Package ID: W_FC_C_10.0.027
Copyright (C) 1985-2007 Intel Corporation. All rights reserved.

Microsoft Incremental Linker Version 8.00.50727.42
Copyright (C) Microsoft Corporation. All rights reserved.

-out:console1.exe
-subsystem:console
console1.obj

C:TempConsole1>link console1.obj
Microsoft Incremental Linker Version 8.00.50727.42
Copyright (C) Microsoft Corporation. All rights reserved.

C:TempConsole1>link console1.obj /OUT:"DebugConsole1.exe" /INCREMENTAL:NO /NO
LOGO /MANIFEST:NO /DEBUG /PDB:"C:TempConsole1debugconsole1.pdb" /SUBSYSTEM:C
ONSOLE

C:TempConsole1>

As you see, at last I have compiled and linked using the command lines that I have found in the project's properties. Obviously, these work.

Steve, do you have any other idea what to do?

Thank you for your help.

Joerg Kuthe

What is the contents of buildlog.htm in your release or debug subfolder of the project?

Retired 12/31/2016
------ Build started: Project: Console1, Configuration: Debug|Win32 ------

Linking...
Link /OUT:"DebugConsole1.exe" /VERBOSE /INCREMENTAL:NO /NOLOGO /MANIFEST:NO /DEBUG /PDB:"C:TempConsole1debugconsole1.pdb" /SUBSYSTEM:CONSOLE "DebugConsole1.obj"
Link: error error_opening_IPO_object_list: couldn't open multi-file optimizations object list


Console1 - 1 error(s), 0 warning(s)

Did you really create your Visual Studio project in the temp folder? That seems very odd and might cause problems. Try creating a project in a normal directory and see if you have the same problem

Retired 12/31/2016

Ok, I have created the console project in a regular directory - and obtained the same error.

But, I checked my setup and found out that I must have installed VS2005 under another login/account on this PC originally. So, I have uninstalled IF10 completely, changed to that other account, reinstalled IF10 - and now IF10 works.

Jrg

Leave a Comment

Please sign in to add a comment. Not a member? Join today