Turning of "chkstk.asm" during debug session

Turning of "chkstk.asm" during debug session

During debugging of my code, the debugger jumps into chkstk.asm before stepping into a subroutine that is called as

CALL foo(array1+array2)

Is there a way to turn of this behavior and avoid having to step through chkstk.asm other than setting breakpoints in the subroutine foo or using the "Run to cursor" feature?


7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Sorry, I forgot to mention. I am using VS2005 with IVF 10.0.027.


Nothing that comes to mind other than avoiding arguments that will require create an array temporary.

Steve - Intel Developer Support

I don't know of anyway to tellthe VS debugger that you're not interested stepping intochkstk.asm. (That routine is called when the arguments to the subroutine you are interested in are being setup up, so when you stop at the line with the CALL, it's the next routine called.)

Other than what you mention, if you do get into chkstk.asm, SHIFT+F11 should return you to the calling program and another F11 should get you into the routine you're interested in.

In the Property Pages for the Solution (not Project), Under Common Properties / Debug Source Files, I have listed all the .asm files I don't want debugged.

I haven't got this set for all my solutions I am working with, so I'm not sure how successful this is, as I still step into the .asm files occasionally. VERY ANOYING! We really want a fix. I first reported this about two years ago, I think.


I agree. Fix it please.


Add _chkstk to the registry key relevant to your version of Visual Studio as described at http://blogs.msdn.com/b/andypennell/archive/2004/02/06/69004.aspx (for vs2010 its HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\NativeDE\StepOver).

Leave a Comment

Please sign in to add a comment. Not a member? Join today