standardU.dll.manifest : general error c1010070: Failed to load and parse the manifest.

standardU.dll.manifest : general error c1010070: Failed to load and parse the manifest.

I want to link Abaqus 6.11-2 to Visual Fortran to run a fortran subroutine in Abaqus. I have Microsoft Visual Studio 2010 (trial version) and Intel Composer XE 2011 (trial version) on my computer. When I run my job in Abaqus, the following error occurs:

Abaqus JOB umatmst3

Abaqus 6.11-2

Begin Compiling Abaqus/Standard User Subroutines

08/04/12 22:14:39

ifort: command line remark #10279: option '/QxW' is deprecated and will be removed in a future release. See '/help deprecated'

ifort: command line warning #10161: unrecognized source type 'Od'; object file assumed

ifort: command line warning #10161: unrecognized source type 'Zi'; object file assumed

ifort: warning #10146: no action performed for specified object file(s)

End Compiling Abaqus/Standard User Subroutines

08/04/12 22:14:39

Begin Linking Abaqus/Standard User Subroutines

08/04/12 22:14:39

Creating library standardU.lib and object standardU.exp

Microsoft Manifest Tool version 5.2.3790.2076

Copyright (c) Microsoft Corporation 2005.

All rights reserved.

standardU.dll.manifest : general error c1010070: Failed to load and parse the manifest. The system cannot find the file specified.

Abaqus Error: Problem during linking - Abaqus/Standard User Subroutines.

This error may be due to a mismatch in the Abaqus user subroutine arguments.

These arguments sometimes change from release to release, so user subroutines

used with a previous release of Abaqus may need to be adjusted.

Abaqus/Analysis exited with errors

I have spent more than 3 weeks searching internet to resolve the problem. It would be very appreciated if anyonecould help me resolve this problem.

Thanks a lot,

Samad

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The following lines:

ifort: command line warning #10161: unrecognized source type 'Od'; object file assumed

ifort: command line warning #10161: unrecognized source type 'Zi'; object file assumed

are the real key. They indicate that the command line given to compile your Fortran subroutines was incorrect. Instead of /Od and /Zi, the line probably had something like .Od and .Zi. You didn't show the script or batch file that is used to compile the Fortran code, but you need to correct it. Once you do that, the other errors will probably go away.

Really, this is an issue with how you are using Abaqus, and you might have fared better had you started with Abaqus support.

Steve - Intel Developer Support

Dear Steve,

Thank you very much for youranswer.
Before comming to this forum, I had called Abaqus Support Center and they said I should call Intel Support Center.
Where can I find the script or batch file that is used to compile the Fortran code? It should be a part of Abaqus, shouldn't it?

Thanks,

Samad

Dear Steve,

Thank you very much for your help.
I found the file compiling and linking fortran subroutines. It is a .env file. As you said, instead of '/Od' and '/Oz' it contained 'Od' and 'Oz' . I changed them and the two warnings were removed,butthe errorstill exists.
The new error file is as follows:
"

Abaqus JOB umatmst3

Abaqus 6.11-2

Begin Compiling Abaqus/Standard User Subroutines

08/05/12 23:45:36

ifort: command line remark #10279: option '/QxW' is deprecated and will be removed in a future release. See '/help deprecated'

End Compiling Abaqus/Standard User Subroutines

08/05/12 23:45:36

Begin Linking Abaqus/Standard User Subroutines

08/05/12 23:45:36

Creating library standardU.lib and object standardU.exp

Microsoft Manifest Tool version 5.2.3790.2076

Copyright (c) Microsoft Corporation 2005.

All rights reserved.

standardU.dll.manifest : general error c1010070: Failed to load and parse the manifest. The system cannot find the file specified.

Abaqus Error: Problem during linking - Abaqus/Standard User Subroutines.

This error may be due to a mismatch in the Abaqus user subroutine arguments.

These arguments sometimes change from release to release, so user subroutines

used with a previous release of Abaqus may need to be adjusted.

Abaqus/Analysis exited with errors

"

The .env file (abaqus_v6.env) is as follows:

"
#

# System-Wide Abaqus Environment File

# -------------------------------------

standard_parallel = ALL

mp_mode = MPI

mp_file_system = (DETECT,DETECT)

mp_environment_export = ('MPI_PROPAGATE_TSTP',

'ABA_CM_BUFFERING',

'ABA_CM_BUFFERING_LIMIT',

'ABA_ITERATIVE_SOLVER_VERBOSE',

'ABA_DMPSOLVER_BWDPARALLELOFF',

'ABA_ELP_SURFACE_SPLIT',

'ABA_ELP_SUSPEND',

'ABA_HOME',

'ABA_MEMORY_MODE',

'ABA_MPI_MESSAGE_TRACKING',

'ABA_MPI_VERBOSE_LEVEL',

'ABA_PATH',

'ABA_RESOURCE_MONITOR',

'ABA_RESOURCE_USEMALLINFO',

'ABAQUS_LANG',

'ABAQUSLM_LICENSE_FILE',

'ABQ_CRTMALLOC',

'ABQ_DATACHECK',

'ABQ_RECOVER',

'ABQ_RESTART',

'ABQ_SPLITFILE',

'ABQ_XPL_WINDOWDUMP',

'ABQ_XPL_PARTITIONSIZE',

'ABQLMHANGLIMIT',

'ABQLMQUEUE',

'ABQLMUSER',

'CCI_RENDEZVOUS',

'DOMAIN',

'DOMAIN_CPUS',

'DOUBLE_PRECISION',

'FLEXLM_DIAGNOSTICS',

'FOR0006',

'FOR0064',

'LD_PRELOAD',

'MP_NUMBER_OF_THREADS',

'MPC_GANG',

'MPI_FLAGS',

'MPI_RDMA_NENVELOPE',

'MPI_SOCKBUFSIZE',

'MPI_WORKDIR',

'MPCCI_SERVER',

'MPCCI_INITIAL_EXCHANGE',

'_MPCCI_CCM_CODE_IDS',

'_MPCCI_CODE_IDSTRING',

'ABAQUS_CCI_DEBUG',

'NCPUS',

'OMP_DYNAMIC',

'OMP_NUM_THREADS',

'OUTDIR',

'PAIDUP',

'PARALLEL_METHOD',

'RAIDEV_NDREG_LAZYMEM',

'ABA_SYMBOLIC_GENERALCOLLAPSE',

'ABA_SYMBOLIC_GENERAL_MAXCLIQUERANK',

'ABA_ADM_MINIMUMINCREASE',

'ABA_ADM_MINIMUMDECREASE',

'IPATH_NO_CPUAFFINITY',

'MALLOC_MMAP_THRESHOLD_',)

import driverUtils, os

compile_cpp=['cl', '/c', '/nologo', '/W0', '/MD',

'/TP', '/EHsc', '/DNDEBUG', '/DWIN32', '/DTP_IP', '/D_CONSOLE',

'/DNTI', '/DFLT_LIC', '/DOL_DOC', '/D__LIB__', '/DHKS_NT',

'/DABQ_NTI_NET', '/DFAR=', '/D_WINDOWS', '/DABQ_WIN86_64',

'/O1', '/I%I']

compile_fortran=['ifort', '/c','/DABQ_WIN86_64',

'/recursive', '/Qauto-scalar', '/QxW', '/nologo', '/Od', '/include:%I', '/Od', '/Zi'] #<------Editted line

# '/recursive', '/Qauto-scalar', '/QxW', '/nologo', '/Od', '/include:%I', 'Od', 'Zi']#<------The original line

link_sl='cmd /c "LINK /DEBUG /nologo /INCREMENTAL:NO /subsystem:console /machine:AMD64 /NODEFAULTLIB:LIBC.LIB /NODEFAULTLIB:LIBCMT.LIB /DEFAULTLIB:OLDNAMES.LIB /DEFAULTLIB:LIBIFCOREMD.LIB /DEFAULTLIB:LIBIFPORTMD.LIB /DEFAULTLIB:LIBMMD.LIB /DEFAULTLIB:MSVCRT.LIB /DEFAULTLIB:kernel32.lib /DEFAULTLIB:user32.lib /DEFAULTLIB:advapi32.lib /FIXED:NO /dll /def:%E /out:%U %F %A %B oldnames.lib user32.lib ws2_32.lib netapi32.lib advapi32.lib && mt /manifest %U.manifest /outputresource:%U;2 && del %U.manifest"'

link_exe='cmd /c "LINK /DEBUG /nologo /INCREMENTAL:NO /subsystem:console /machine:AMD64 /STACK:20000000 /NODEFAULTLIB:LIBC.LIB /NODEFAULTLIB:LIBCMT.LIB /DEFAULTLIB:OLDNAMES.LIB /DEFAULTLIB:LIBIFCOREMD.LIB /DEFAULTLIB:LIBIFPORTMD.LIB /DEFAULTLIB:LIBMMD.LIB /DEFAULTLIB:MSVCRT.LIB /DEFAULTLIB:kernel32.lib /DEFAULTLIB:user32.lib /DEFAULTLIB:advapi32.lib /FIXED:NO /LARGEADDRESSAWARE /out:%J %F %M %L %B %O oldnames.lib user32.lib ws2_32.lib netapi32.lib advapi32.lib && mt /manifest %J.manifest /outputresource:%J;1 && del %J.manifest"'

# Link command to be used for MAKE w/o fortran compiler.

# remove the pound sign in order to remove the comment and have the file take effect.

#

#link_exe='cmd /c "win64CmpWrp -m64 -intel10x LINK /nologo /INCREMENTAL:NO /subsystem:console /machine:AMD64 /NODEFAULTLIB:LIBC.LIB /NODEFAULTLIB:LIBCMT.LIB /DEFAULTLIB:OLDNAMES.LIB /DEFAULTLIB:MSVCRT.LIB /DEFAULTLIB:kernel32.lib /DEFAULTLIB:user32.lib /DEFAULTLIB:advapi32.lib /FIXED:NO /LARGEADDRESSAWARE /out:%J %F %M %L %B %O oldnames.lib user32.lib ws2_32.lib netapi32.lib advapi32.lib && win64CmpWrp -m64 -intel10x mt /manifest %J.manifest /outputresource:%J;1 && del %J.manifest"'

# MPI Configuration

mp_mode = THREADS

mp_mpi_implementation = NATIVE

mp_rsh_command = 'dummy %H -l %U -n %C'

mp_mpirun_path = {}

mpirun = ''

progDir = os.environ.get('ProgramFiles','C:\\Program Files')

for mpiDir in ('Microsoft HPC Pack', 'Microsoft HPC Pack 2008 R2', 'Microsoft HPC Pack 2008', 'Microsoft HPC Pack 2008 SDK'):

mpirun = progDir + os.sep + mpiDir + os.sep + 'bin' + os.sep + 'mpiexec.exe'

if os.path.exists(mpirun):

mp_mpirun_path[NATIVE] = mpirun

break

if os.environ.has_key('CCP_HOME'):

from queueCCS import QueueCCS

queues['default'] = QueueCCS(queueName='share')

queues['share'] = QueueCCS(queueName='share')

queues['local'] = QueueCCS(queueName='local')

queues['genxmlshare'] = QueueCCS(queueName='genxmlshare')

queues['genxmllocal'] = QueueCCS(queueName='genxmllocal')

del QueueCCS

mpirun = os.path.join(os.environ['CCP_HOME'], 'bin', 'mpiexec.exe')

if os.path.exists(mpirun):

mp_mpirun_path[NATIVE] = mpirun

run_mode=BATCH

if mp_mpirun_path:

mp_mode=MPI

del progDir, mpiDir, mpirun

graphicsEnv = driverUtils.locateFile(os.environ['ABA_PATH'],'site','graphicsConfig','env')

if graphicsEnv:

execfile(graphicsEnv)

else:

raise 'Cannot find the graphics configuration environment file (graphicsConfig.env)'

del driverUtils, os, graphicsEnv

abaquslm_license_file="27000@r0147209"

doc_root="http://R0206374:2080/v6.11"

doc_root_type="html"

academic=RESEARCH
"

I wouldappreciated it if you could pleasehelp me more.

Thanks,

Samad

There is some error running the Manifest Tool (mt.exe) from the set of commands in your environment file. I would guess that it is unable to find standardU.dll. The .env file you show is something specific to Abaqus and I am not completely sure how to interpret it, as it obviously does some symbol substitution. But let me suggest that you change:

/outputresource:%J;1

to:

/outputresource:%J;#1

in the two places it appears.

Steve - Intel Developer Support

Dear Steve,

Than you for your comment.
I made your suggested change in the .env file, but it did not sole the problem.

Thanks a lot,

Samad

Dear Steve,

Than you for your comment.
I made your suggested change in the .env file, but it did not sole the problem.

Thanks a lot,

Samad

Given that you have had several transcription errors in the .env file already, I wonder if there are others. Your problem is not with Intel Fortran. If you can provide a log of the commands actually executed, perhaps we can help you, but otherwise we're just guessing. The basic issue seems to be that the mt command is being asked to do something to a file it can't find. Is your DLL actually in the location you think it is? What is the full path to the DLL?

Steve - Intel Developer Support

Well, it has been a while since you have posted the problem and hopefully you have already solved it. Otherwise, you can try to add
"/manifest /manifestfile:%U.manifest" to the first line of the link_sl in the .env file as follows:

link_sl='cmd /c "LINK /manifest /manifestfile:%U.manifest /nologo /INCREMENTAL:NO /subsystem:console /machine:AMD64 /NODEFAULTLIB:LIBC.LIB /NODEFAULTLIB:LIBCMT.LIB /DEFAULTLIB:OLDNAMES.LIB /DEFAULTLIB:LIBIFCOREMD.LIB /DEFAULTLIB:LIBIFPORTMD.LIB /DEFAULTLIB:LIBMMD.LIB /DEFAULTLIB:MSVCRT.LIB /DEFAULTLIB:kernel32.lib /DEFAULTLIB:user32.lib /DEFAULTLIB:advapi32.lib /FIXED:NO /dll /def:%E /out:%U %F %A %B oldnames.lib user32.lib ws2_32.lib netapi32.lib advapi32.lib && mt /manifest %U.manifest /outputresource:%U;2 && del %U.manifest"'

It solved the problem for me.

Hello,

This post is quite old but I was wondering if anyone could help me.
I had the same errors when trying to link Abaqus 6.10 to Visual Studio 10.0 x64 and Intel Fortran 11.1 x64 (both compatible with this version of Abaqus) on Windows 7 x64:

using abaqus command prompt:

C:\SIMULIA\TEMP>abaqus job=Job-1-VUMAT user=VUMAT_file
Begin Compiling Single Precision Abaqus/Explicit User Subroutines
1/9/2014 4:36:10 PM
End Compiling Single Precision Abaqus/Explicit User Subroutines
1/9/2014 4:36:11 PM
Begin Linking Single Precision Abaqus/Explicit User Subroutines
1/9/2014 4:36:11 PM
         Creating library explicitU.lib and object explicitU.exp
Microsoft (R) Manifest Tool version 5.2.3790.2076 Copyright (c) Microsoft Corporation 2005.
All rights reserved.

explicitU.dll.manifest : general error c1010070: Failed to load and parse the manifest. The system is unable to localize the specified file.
Problem during linking - Single Precision Abaqus/Explicit User Subroutines.   This error may be due to a mismatch in the Abaqus user subroutine arguments.   These arguments sometimes change from release to release, so user subroutines   used with a previous release of Abaqus may need to be adjusted.

I tryed to apply the suggestions from the folowing websites but they were written for 32-bit systems if I'm not wrong:
http://polymerfem.com/showthread.php?910-succeed-in-installing-ABAQUS-subroutine
 

What could I try to solve this problem?

Thank you in advance for your time and attention.

Best regards,

David Melo - Portugal

Without seeing the exact commands that the Abaqus script used, it's difficult to diagnose this. In general, this error means that the DLL was created in a different place than the manifest tool (mt.exe) was told to look for it.  I suggest you start with Abaqus support for help with this.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today