Installation issue (Command Prompt Mode): "the specified configuration type is missing."

Installation issue (Command Prompt Mode): "the specified configuration type is missing."

Hello all,

After installing Intel Visual Fortran Compiler XE 2011 Update 10 for Windows (VS10 shell), attempting to start the Command Prompt "Intel 64 Visual Studio 2010 mode" starts a prompt with the message:

Intel Parallel Studio XE 2011 SP1
Copyright (C) 1985-2012 Intel Corporation. All rights reserved.
Intel Composer XE 2011 Update 10 (package 325)
The specified configuration type is missing. The tools for the
configuration might not be installed.

as a result, attempting to run a sample test program, using ifort test.for generates the .obj file but fails with the message:
ifort: error #10037: could not find 'link'

History of installation:
- Visual Studio was not installed on this machine
- First the incorrect installer was used, i.e w_fcompxe_novsshell_2011.9.300.exe
- uninstalled IVF and installed it again using the correct installer: w_fcompxe_2011.10.325.exe, so that VS 2010 shell is also installed.

Additional question:
the batch file ifortvars.bat seems to always need an argument. this seems new in this version. Is that correct?

Any help/suggestions would be greatly appreciated,
Thanks in advance

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The architecture argument being required has been there for a while, but you should not have to supply the VS version. We know of a problem if you also have Visual C++ 2010 Express installed - do you?

Retired 12/31/2016


No, I do not have Visual C++ 2010 Express.

We have a engineering application which generates Fortran source and a set of scripts to invoke the compiler. I did not recall the scripts specifying arguments for the the ifortvars.bat which is being used in that situation...


This was a change we made in 11.1 (I think) where you have to supply the architecture name. Is your script doing that? Does clicking the compiler-installed Start menu shortcut for a command prompt session work?

Retired 12/31/2016

I think I confused things by adding my additional question regarding my scripts. I haven't installed these scripts/application yet.

The problem I'm having is when launching the compiler-installed start menu shortcut for the command prompt.

Ok. Please right click on that shortcut, select Properties. Copy the "Target" field and paste it into a reply here. It should look similar to this, though the .bat file may be different:

C:\Windows\SysWOW64\cmd.exe /E:ON /V:ON /K ""C:\Program Files (x86)\Intel\Composer XE 2011 SP1.325\bin\ipsxe-comp-vars.bat" intel64 vs2010"

The error you're getting is due to the Microsoft vcvarsall.bat file being invoked when it really shouldn't even exist because you have the VS Shell. Have you installed any VS2010 product separately in the past? Does the folder C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC exist?

Retired 12/31/2016

ok, here it the target:
C:\Windows\SysWOW64\cmd.exe /E:ON /V:ON /K ""C:\Program Files (x86)\Intel\Composer XE 2011 SP1\bin\ipsxe-comp-vars.bat" intel64 vs2010"

I never installed any VS2010 product before.
Yes, the folder VC exists in the folder C:\Program Files (x86)\Microsoft Visual Studio 10.0\ and it does contain the vcvarsall.bat file.

If that folder exists, someone installed a VS2010 product before, including VC++ 2010 Express. Its presence is confusing the scripts. As a first experiment, rename that VC folder to VCX and then try the shortcut again.

If that works, right click Computer, select Properties, Advanced System Settings, Environment variables. Under System variables, find VS100COMNTOOLS and delete it. That should take care of the problem.

Retired 12/31/2016

That worked! Thanks!

I still don't understand what other application would have installed VS2010 (I've had that machine since it was purchased), and I'm not a developer.

The date on that VC folder is 5/2/2012, which is when I installed IVF...

Thanks so much for your help, I can now proceed to install my other application....


Leave a Comment

Please sign in to add a comment. Not a member? Join today