Missing .lib's

Missing .lib's

I have spent the past 3 weeks testing the Intel Visual Fortran Comiler for Windows and had great success. I just purchased the compiler and installed it.....now following the same procedure that I did with the trial version I am getting link errors that libraries cannot be opened. I ran compilervars.bat to the Intel environment variables. I am developping the 64-bit code on a 64-bit machine. I must be missing something that is different between the trial and offical version.

I am getting the following error during linking:

LINK: fatal error LNK1104: cannot open file 'uuid.lib'
LINK: fatal error LNK1104: cannot open file 'ADVAPI32.lib'

Any help would greatly appreciated!

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Do you have Visual Studio installed - even the Shell available with the product? The libraries you're looking for are in the Windows Platform SDK. This is installed with Visual Studio. Can you show me the output of running compilervars.bat?

Retired 12/31/2016

Here's an article which may or may not relate to that problem. I've encountered that message in the past, with now obsolete components. In this case, it seemed that VS Express created a conflict.


I have attached a screen capture of the results of running "comilervars.bat intel64". I am compiling and linking via the command line. I did not have Visual Studio installed on my my machine...so I downloaded the compiler version that included Visual Studio. When using the trial copy of the compiler, I had to first download a trail version of Visual Studio from Microsoft before being able to download, install, and run the Intel compiler...that is the difference in my installation procedure. Thanks much.



Downloadimage/jpeg Capture.JPG90.79 KB

From the command prompt, please show me the output of these commands:


Did you uninstall the trial version of VS2010 before installing the compiler (including the shell)?

Retired 12/31/2016

I have attached a screen capture with the output from CLI commands. I did uninstall all of Visual Studio before proceeding. I assume that Visual Studio was installed along with Visual Fortran as it was downloaded in the same file.


Downloadimage/jpeg EnvCLI.JPG22.6 KB

Steve....thanks much for your help. I decided to unistall everything and reinstall.....now everything is working...not sure what went wrong.

Glad to hear it.

Retired 12/31/2016


Steve Lionel (Intel) 写道:

Did you uninstall the trial version of VS2010 before installing the compiler (including the shell)?

Steve, I got the same problem and my answer to your question is NO, I did not uninstall the VS2010 libraries and shell, because I need my applications to be run on WinXP as well, and IVF\VC\lib for VS2010 is blocked and can not be installed AFTER VS2012 Pro.

I installed and uninstalled IVF 2013 with and without 2010 and 2013 so many times, getting the same problem that the whole thing became a mess, and I have no IVF now and can’t install it!

I got an error message while uninstalling IVF 2013 last time like the error no 1 (attached). I fixed it using the MS “Fix It”. But back to installation of IVF, I get 2 errors as attached, and no installation.

What to do?

Trying to attach a second time.


Downloadimage/jpeg insterr1.jpg15.01 KB
Downloadimage/jpeg insterr2.jpg24.83 KB

VS2012 now has a Service Pack 1 that handles the problem about building for XP. Its C libraries are now XP compatible and it installs an XP-compatible platform SDK.

So please uninstall everything, install VS2012, its SP1, then reinstall Fortran.

Retired 12/31/2016

Steve, it was your ”sticky topic” about XP compatibility on the top of this forum that made me to create problem for myself. Maybe time to remove it or at least add this new information there?

Ok - I will do that.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today