Indenting block of code using Tab and Shift+Tab does not work?

Indenting block of code using Tab and Shift+Tab does not work?

I am testing the integration of Intel Visual Fortran Composer XE 2001 Update 8 in Visual Studio 2010 to find out if it makes sense to switch from Visual Studio 2008 to 2010. I discovered following problem:

When a block of code is selected and Tab is pressed, the block is deleted and the caret moves by one tab size. In VS 2008, the selected block was moved instead which is the behavior I want. If I use the corresponding icons for indenting in the toolbar, everything works well. I experience this problem no matter how I select the block - directly in the code, by selecting whole lines, or with the Alt key.

Am I doing something wrong or has anything changed in VS 2008 vs. VS 2010?

By the way, is there any plan to have the similar functionality of the integration (especially highlighted block, matching brackets, list of subroutines and functions in a file, going to definition, finding all references) in VS 2008 like it is now in VS 2010?

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Block indention with tab and shift + tab works in Visual Studio 2010.I tested it with Update 8. Perhaps you turned it off somehow?

I am not aware of any plans to update the Visual Studio 2008 integration with those features.

OK, thank you for your reply regarding the VS 2008 integration; I expected that and wanted to confirm.

Concerning the block indentation, where should I look to find out if I accidentally turned it off? I did not find any options related to this. I tried changing the indentation style from Smart to Block, but it did not help. What changed the behavior was trying this in free format files instead of fixed format ones. While block indentation using Tab and Shift+Tab works as expected in free format files, it does not work in the fixed format ones, at least on my computer (Windows 7 Professional 64-bit, Visual Studio 2010 Ultimate, Intel Composer XE 2011, Update 8).

Indeed, block indention with Tab is not working for fixed format fortran files. I found that Shift+Tab is working though.

I have escalated this issue to development. The issue number is DPD200177883.I will post any updated I receive on this issue to this thread.

We are planning to include a fix for this issue in the next major release which has been scheduled for later this year.

Regards,
Annalee

One this is targeted to be fixed, would you please consider chganging the indent of empty lines? When a block of code to be indented contains empty lines, the indentation does not change for them.

The developers are now planning to include the indenting with tab issue fix in the next release of 12.1 rather than the next major release. This release is currently scheduled for late June

As for indenting empty lines, some users prefer leaving blank lines unindented. The standard behavior in Visual Studio is not to intent empty lines. We are unlikely to change this unless Visual Studio changes this for all languages.

Indeed when the cursor is placed mid-line and tab is pressed, nothing happens (fixed format files, win7-x64). Shift-tab works as expected. I was trying to format a line continuation statement with the tab key and I couldn't.

Hello John and Jirina,

This issue has been fixed in the latest update, Intel VisualFortran Compose XE 2011 update 11 for Windows*.

Regards,
Annalee
Intel Developer Support
* Other names and brands may be claimed as the property of others.

Leave a Comment

Please sign in to add a comment. Not a member? Join today