VS 2010 - how do I get that nice F1 feature to work?

VS 2010 - how do I get that nice F1 feature to work?

It used to be with earlier VS 2008 and VS 2005 you could highlght a keyword, and it would jump right to
help for that keyword by pressing F1. But now it doesn't work the same way.

What it gives me is stuff unrelated to Fortran. I tried playing with the Help Library Manager, but it says the Fortran compiler stuff is "local." Which means the stuff should already be there.

I can use the HELP pull-down menu to search for a Fortran topic, but that's not the same as the F1 feature we used to have. It's about the 5th item down on the pull down menu.

Any clues about this? I didn't see an option to limit it to Fortran topics.

36 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I figured this out for someone else a while ago but forgot what the answer was. I'll find it again and let you know.

Retired 12/31/2016

BTW, one reason is that I was looking for a utility that would give me
the contents of a folder.

For example if I navigate around with CHANGEDIRQQ, I want to see what files are listed there, and
what subfolders so I can jump to those if necessary.

From looking at the HELP menu, I did not see what category that routines like that were listed under.
Otherwise, I could go there and see what's available.

GETFILEINFOQQ is the routine you want.

Retired 12/31/2016

It turns out that the thread I was remembering was for VS2008. But the same idea should apply. If you have VS set to search local help only, not online, you should get only the Fortran help.

Retired 12/31/2016

That does not work. It onlt tells me "That topic cannot be found."

But I cant add the Fortran stuff from online either. The help library manager

says its "local."

Who is testing this stuff?

I guess it's US, right?

Bill, this works for most people, but I have seen a few reports of problems. Usually an uninstall and reinstall of Fortran takes care of it.

Retired 12/31/2016

Well I just sat down to issue a complaint about the same exact problem, and here this was already posted! Good to know I am not alone.

I had already suspected the problem was missing local help, so I have already tried to install it, using:

VS help > Manage help settings > Choose online or local > I want to use local,
Install content from online > Install par.stud.xe22011 > local

But this doesn't work, even though the Help Settings has the "I want to use local help" selected.

From the overall behavior of this, it appears that the local help file(s) was not included in the upgrade download I made; that we are expected to download the help separately, which does not work.

Surely there is a bug here somewhere.

Is there some way I can tell whether I have the necessary local help file, and install it manually?

And, if it's any clue, I also have the problem that VS will not print in color (even though the options are clearly set for that, and VS8 worked fine).

The operative words in number 6 are:


hee - hee - hee ! ! !

I am wondering if having a co-existantVS 2008 might be aggravating this.

As far as I can tell, VS 2010 and Fortran only gives you local help.
At least "on line" help is not an option so far.

Remember that old song - "You'll never walk alone?"

I have reproduced this lack of F! support with a system with just Microsoft Visual Studio 2010 and no other. I have filed this asDPD200176966.By the way, we do offer online help. Here is a description of how to access it from the documentation. I checked and it does work on the same system where F1 is failing.
Using Online Help

The online help for this
product is a compiled Help system, launchable in the Visual Studio integrated
development environment (IDE) Document Explorer window. It provides information
about concepts, procedures, and the user interface.

To launch help:

  1. Start Microsoft Visual Studio.

  2. From the Help menu, choose Intel Visual Fortran Composer XE >
    Intel Visual Fortran Composer XE Help

The Intel documentation
displays in a separate window.

I will update this thread if I get a workaround or when a compiler resolves the problem.Thanks for reporting it.



Attaching or including
files in a post

I'm not sure if your response is intended to address my RELATED concern, expressed in no. 7. The issue is that I am seeing online help OK, but not local help.

Your response is that the F1 problem can exist when online help is OK. But, can the F1 problem exist when local help is OK?

And, how can I get local help to work? Whenever I ask for help, it is displayed in a separate, via Internet Explorer, accessing Isn't this online help, not local?

I have tried re-installing Fortran, and I see the boxes to check for installing local help, but I don't think it is working. If I really had local help working, would the F1 feature then also work?

I believe I am seeing the same thing you are (Can't see your link to see your error message). I set the Help options to use local help and the try to highlight various Fortran keywords and then press F1. I get the error below. Note that the instructions I included for "online help" are different than using Microsoft Visual Studio to search online by toggling off the local help.



Attaching or including files in a post

Error Message:

The topic you requested could not be found in local help.

Have you installed the local help content?

How to install and configure local help using Help Library Manager.

Check online for your topic at:


Other options to try

Do you have the right content installed locally?

How to add new content to your local help store with Help Library Manager.

How to enable online only help.

That etc address is local help.

At least the address is a local address,
from what I have been told.

when I go to the Help manager, there are many topics,
and most give you an oprion between LOCAL and ON-line.

However, the Fortran compiler option is only LOCAL.

I take that to mean you cannot get on line help with
the Fortran compiler, unless you use that search URL.

I am not sure about the search URL, but the online help is the same as the installed help (which also shows up with a search, index and table of contents). Does this online help not meet your needs? If not I would like to hear more and we could create a feature request.



Attaching or including files in a post

Well, this "online" help (which is apparently actually local--it's very confusing), is OK, BUT it doesn't solve the F1 problem.

In VS08, F1 could be made to work simply by setting VS to use local help. In VS10 it apparently does not fulfill this role.

So, we are still looking for a solution to the original question--WHAT HAPPENED TO THE F1 FEATURE AND HOW TO GET IT BACK.

The missing F1 feature is a bug which I have replicated and reported to engineering as noted in a previous post. They have suggested workarounds for a manual install of the F1 help, but so far I have been unable to make that work (I think the error is in the F1 help file itselfand not in the install). I will keep you updated on this thread with any workarounds or when a compiler that resolves the issue is released.



Attaching or including files in a post

I can get help from VS 2008, but when I do the same thing for VS 2010 projects, I don't get anywhere.

When I try to download help from on-line, I get a blank screen, and nothing happens.

So the HLM is totally non-functional.

It appears that usable stuff gets loaded with VS 2008, but nothing is loaded with VS 2010.
And nothing can get downloaded to there either. So in a VS 2010 project, we are completely shut out.

If there was a WEB site we could go to , then we could do a search there. Not as convenient,
but better than nothing at least.

So, is the Fortran stuff included along with the VS stuff? Maybe if we could have a downloadable file,
that would help for the time being. Otherwise, I have to go to a VS 2008 project to get the
reference info. They probably should be in separate files anyway.
(1) Fortran refernce
(2) Visual Studio reference

Then when you are working on a project it points to Fortran reference.

The F1 help does not work with Update 7 in VS 2010. I am doing what I can to try to find a workaround, but the installed F1 files do not install correctly into Microsoft Visual Stuido. F1 is just a small portion of the help (it is the context sensitive help for your code and only been available in recent releases). If you want to reference or look up something in our documentation it is installed here:Start -> All Programs =>Intel Parallell Studio XE 2011 => Documentationor posted online here:http://software.intel.com/en-us/articles/intel-fortran-composer-xe-documentation/In additon to the location mentionned above. If these don't meet your needs, can you be more specfic about the type of information you are looking for and I can respond to that.Thanks,



Attaching or including
files in a post

The HELP function does not work at all with VS 2010, at least on my system(s).

I think its because I already had it on VS 2008, and that pre-empts anything I do with VS 2010.

It wants to use on-line help, but cannot access any information, nor can I download anything from the
Web site. When I try to do that, I get a blank window and nothing is happening.

You don't have anything like remote assist, do you? That would save a lot of time,
becuase you can see directly what the problem is.

Maybe if you can tell me the location where the local help is supposed to be I can look at it.

I have the same thing installed on computer #2, and with all the same symptoms.

And as I said before, the HLM does not allow me to download any Fortran stuff.

My experience was that the Fortran stuff was installed when the compiler was installed. The only glitch is that context sensitive help doesn't work properly on Windows XP machines (but it is ok on Vista - but that could be due differences with Fortran installation history). The help is still there. The glitch is an indexing issue or similar - pressing F1 doesn't bring up a matching articles even though there may be several suitable articles.

(Because it can't find a topic, the help system does a search for the keyword. Consequently the Results tab will almost invariably have a list of articles, one of which is the one that you want - you just need to select the article.)

Make sure that you are using local help. From within Visual Studio select Help > Manage Help Settings. Then in the resulting dialog choose either "Settings" up the top, or "Choose online or local help". Make sure that local help is selected.

The local help system in VS2010 works through a little web server that it runs on your computer (you'll see an icon appear down in the system tray when the help viewer starts up. That's why people are seeing IP addresses with in them (reserved address for the local machine).

Once you are sure that you are using local help - what does the contents section say?

I am sure I am using local help (at least, since others here have explained that local help is now accessed through Internet Explorer, unlike it used to).

I have the same problem on my XP machine at work and my Win& machine at home.

The F1 key brings up a dialog that says "The topic you requested could not be found in local help" and goes on to suggest other helpful things that are in fact not helpful at all. I do not see the "list of articles, one of which is the one that you want" that you refer to. And even if that were the case, that would be a far cry from the convenience offered by F1 in the past.

For what it's worth, on both computers I previously had Fortran10 with the supplied VS08 shell installed, and I upgraded to Fortran 12.1 withthe suppliedVS10 shell.

Although VS10 has some nice new features, they do not make up for the loss of instant F1 context-sensitive help, and the loss of print-in-color capability. I'd really like to return to VS08 with Fortran 12.1--but I'm afraid of all the potential hassle involved.

My local help doesn't come via internet explorer - it is delivered via the Help Viewer (which I strongly suspect is just a modified browser - given it connects to a web server anyway). When I configure help to be online then internet explorer is used (and I can connect to the local webserver using internet explorer manually), but perhaps the application used for local help is also configurable or is subject to other installation/system vagaries.

An example of what I see after I press F1 with the implicit keyword highlighted in the VS editor. This is using the VS2010 shell with service pack one, with ifort 12.1.7's integration (previous versions of ifort having been replaced as newer versions were released) on Windows XP SP3. I see the same with the full professional version of VS2010 SP1 on a different machine (still Windows XP SP3, ifort 12.1.7). On another machine with VS2010 professional on Vista with ifort 12.1.7 installed in parallel with 12.0.5, F1 works as expected.

What do you guys see?

The F1 feature does not work for me either way.

But I have VS 2010 installed to two computers, and the HELP for
Fortran is not available on one of them. I can't get it on-line either.

That stuff about the Help Library Manager doesn't work either (at least for me).

Possibly the only way to resolve the issue is if someone can take a look using Remote Assist on my
computer and see what's installed.

As I said before, I think co-existing VS 2008 might be causing this.

The F1 feature does not work for me either way.

But I have VS 2010 installed to two computers, and the HELP for
Fortran is not available on one of them.

I get VS 2010 SHELL when I open it, but that came with the Fortran download.

Is my stuff being blocked? About half the time the reply never appears.

Hi Wendy back again (I was on vacation yesterday). I can certainly set up a remote sharing to see your system if that would be helpful. Let me take the thread privately so we can work out the details and then I can post the results back to the thread.



Attaching or including files in a post

Has any progress been made on this F1-instant-context-help problem? I notice that Update 8 has become available since this was reported. Not being thrilled about the introduction VS2010 (some nice new features but with questionable implementation and some old things that don't work well any more)--which I feel overall was a step backward, I don't want to spend any more time beta testing new versions unless I know what problems have been fixed.


I am checking with the developer on status of a fix. It will not be in Update 8 which had code frozen before this bug was reported.



Attaching or including files in a post

I don't think this is a bug, per se. The feature works if the local help is installed. As we can see from Bill's other threads, something prevented local help from being installed. I gave him some suggestions to get it working.

Retired 12/31/2016

I don't think the feature necessarily works if local help is installed. As has been determined from my postings in this thread, I have local help installed (not obvious that it's local but that's what I am told; see above) and F1 help does not work.

Just installed the latest version (Update 8) and pleased to find that F1 does bring up Fortran help on my machine desipte still having VS2008 / Version 11 installed. Is web based help not local, but appears to be IVF specific. eg highlighting 'SUM' and pressing F1 brings up the following web page

Glad you didn't have any problems -

Are you 32 or 64 bit?

Do you have the "full monty" or the VS 2010 SHELL?

My problem might be related to the specific package I was trying to install.

That URL looks like a LOCAL reference to Help contant, since it starts
with etc. It would be nice if it COULD reference something on the Web directly.

But everything I have seen so far says otherwise.

Quoting davidspurr
Just installed the latest version (Update 8) and pleased to find that F1 does bring up Fortran help on my machine desipte still having VS2008 / Version 11 installed. Is web based help not local, but appears to be IVF specific. eg highlighting 'SUM' and pressing F1 brings up the following web page

It is local. It is connecting to a "web server" Visual Studio established on your own PC - the address is "localhost" and always refers to the current computer.

Retired 12/31/2016

If you will permit my "soap box" - - - - - -Wouldn't it make MUCH MORE SENSE to have on-line help forthe Fortran?That way, any changes or correction would immediately be available to ALLFortran users, regardless of their installation package. And a lot of these problems wouldgo away.They could still install it locally in case they don't have an Internet connection.Like a software manager once told us: "Mysterious and Wonderful" gets you FIRED.

Note my F1 help also was restored with the Update 8, although Bills help was broken with it and we are working that issue in a private version of this thread and I will join back up with a root cause when we get to it.

Wendy D.
Intel Developer Support

Quoting Steve Lionel (Intel)

It is local. It is connecting to a "web server" Visual Studio established on your own PC - the address is "localhost" and always refers to the current computer.

Oops, should have noticed that but was focussed more on the "IntelFortran" at the end of the link.

I too have just installed update 8 and find that this pesky problem (F1) is now fixed. Hooray!

Now if the key problem were fixed (see other thread) (it is not) I could actually use VS2010!

Leave a Comment

Please sign in to add a comment. Not a member? Join today