Visual Studio has encountered an exception.

Visual Studio has encountered an exception.

I have VS2010 installed on 2WINDOWS 7 64-bit systems. I have just updated the fortran compiler on both systems from "w_fcompxe_novsshell_2011.5.221" to "w_fcompxe_novsshell_2011.7.258". The updates appeared to install without a hitch. However, on both systems, I get the following error when I open the solution (double-click the .vfproj file): "Visual Studio has encountered an exception. This may be caused by an extension. You can get more info...."

Has anyone else encountered this and resolved it? If so, what is the resolution?

Thanks!

26 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

1st Q woiuld be: do you get the same error if you open VS2010 and then navigate to the project file? (as opposed to double clicking the file from windows?)
and/or have you opened a vfproj file from VS2010 since the update?
And do you have different versions of VS on the system?
if it only happens on a double click from Windows i'd guess it's an issue with opening the wrong version of VS??

I get the same error when I double-click the project file to open,and when Iopen VS2010 first andthen open the project from there, and also when using the context-menu using the "Open With" command pointing to VS2010.

This error occurred immediately after updating the fortran compiler on the first attempt to open the project. It is consistent in that it occurs every time I open the project. I can click "OK" on the dialog box to close the error message and then continue to work with no apparent ill-effect.

I have VS2008 installed but have been using VS2010 exclusively for some time now with no problems.

This behavior has occurred on 2 independent systems but both with Windows 7 64-bit OS and VS2010 immediately after updating to the latest fortran compiler.

Can you give us the Help => About in Visual Studio to see what service packs and other IDEs are installed in MIcrosoft Visual Studio?

Wendy
Intel Developer Support

I saw the exact same behavior last night on a Window Server 2003 (32bit)
machine that I updated from IVF12 Update 4 to IVF12.1 Update 7. I'll
post my VS2k10 Help=>About in the morning.

I got the exact same error message and behavior last night after I upgraded my Server 2k3 (32bit) machine from IVF12 Update 4 to IVF12.1 Update 7 last night. I'll post my VS2k10 Help->About tomorrow morning.

Sorry, stale test reply

I am out of the office today but will provide the information tomorrow morning when I am back in the office. Thanks!

Here is the information from VS2010 Help => About:

Microsoft Visual Studio 2010

Version 10.0.30319.1 RTMRel

Microsoft .NET Framework

Version 4.0.30319 RTMRel

Installed Version: Professional

Microsoft Office Developer Tools 01018-587-3345904-70071

Microsoft Office Developer Tools

Microsoft Visual Basic 2010 01018-587-3345904-70071

Microsoft Visual Basic 2010

Microsoft Visual C# 2010 01018-587-3345904-70071

Microsoft Visual C# 2010

Microsoft Visual C++ 2010 01018-587-3345904-70071

Microsoft Visual C++ 2010

Microsoft Visual F# 2010 01018-587-3345904-70071

Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer 01018-587-3345904-70071

Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010 01018-587-3345904-70071

Microsoft Visual Web Developer 2010

Crystal Reports Templates for Microsoft Visual Studio 2010

Crystal Reports Templates for Microsoft Visual Studio 2010

Hotfix for Microsoft Visual Studio 2010 Professional - ENU (KB2542054) KB2542054

This hotfix is for Microsoft Visual Studio 2010 Professional - ENU.

If you later install a more recent service pack, this hotfix will be uninstalled automatically.

For more information, visit http://support.microsoft.com/kb/2542054.

Intel Visual Fortran Package ID: w_fcompxe_2011.7.258

Intel Visual Fortran Composer XE 2011 Update 7 Integration for Microsoft Visual Studio* 2010, 12.1.3518.2010, Copyright (C) 2002-2011 Intel Corporation

* Other names and brands may be claimed as the property of others.

Microsoft Visual Studio 2010 SharePoint Developer Tools 10.0.30319

Microsoft Visual Studio 2010 SharePoint Developer Tools

Security Update for Microsoft Visual Studio 2010 Professional - ENU (KB2251489) KB2251489

This security update is for Microsoft Visual Studio 2010 Professional - ENU.

If you later install a more recent service pack, this security update will be uninstalled automatically.

For more information, visit http://support.microsoft.com/kb/2251489.

Thanks for the information. Can you try following the steps in this article and see if it resolves the error. If a step fails please post the details.

------

Wendy

Attaching or including files in a post

We have encountered thisproblem ontwo workstations, of several.

One machine has VS 2010, 2008, and the Intel partner VS 2005 installed.
The other has only VS2010 installed, but has relics from VS 2008 (directories in Program Files).

Have read over the article in your recent post.

Only 4 dlls in the VFPackages folder: VFAVWin, VFHieEditor, VFProj, VFProjConvert.

The version of VFProj.dll looks correct.

Attached is the Help About from VS 2010.

Attachments: 

AttachmentSize
Downloadtext/plain vs_details.txt3.51 KB

C:\Program Files (x86)\Microsoft Visual Studio 10.0\Intel Fortran\VFPackages containing 4 dlls:

VFAVWin.dll

VFHieEditor.dll

VFProj.dll

VFProjConvert.dll

I may have stumbled on the solution though I do not have an explanation. It occurred to me to rename the solution file (project.sln) to something else (project.xxx) so that VS2010 would rebuild the solution file. I launched my project and did not get the error. I saved the new solution file. I launched and exited my project several times with no error. I then deleted the new solution and renamed my original solution back to project.sln. Again, I launched and exited several times with no error. So, at present, I cannot force the error to reoccur.

My Help -> About is at the bottom of this post.

From Step 2 of the "Troubleshooting Fortran..." page that Wendy linked on the previous page of replies, I only have (the same as Glenn) 4 DLLs present:

VFAWin.dll
VFHieEditor.dll
VFProj.dll
VFProjConvert.dll

According to the linked page, I seem to be missing:
VFFortSvc.dll
VFToolOpt.dll

This was an upgrade from IVF 12 Update 4 to IVF12.1 Update 7.

The error popup I am getting suggests running devenv with /log and looking at a given file (Application Data\Microsoft\VisualStudio\10.0\ActivityLog.xml). I did that and the following entry stuck out to me:

241
2011/11/07 18:34:27.444
Error
Editor or Editor Extension
System.NullReferenceException: Object reference not set to an instance of an object.
at Intel.Fortran.IFLangService.DropDownBar.GetNearestScope(Int32 line, List`1 scopes)
at Intel.Fortran.IFLangService.DropDownBar.CalculateNestedSelection(Int32 line)
at Intel.Fortran.IFLangService.DropDownBar.CaretPositionChanged(Object sender, CaretPositionChangedEventArgs e)
at Microsoft.VisualStudio.Text.Utilities.GuardedOperations.RaiseEvent[TArgs](Object sender, EventHandler`1 eventHandlers, TArgs args)

I'll try Glenn's method and see if that fixes anything. Hopefully this information helps.

- Matt
---------------------------------

Microsoft Visual Studio 2010
Version 10.0.30319.1 RTMRel
Microsoft .NET Framework
Version 4.0.30319 RTMRel

Installed Version: Professional

Microsoft Office Developer Tools 01018-532-2002102-70812
Microsoft Office Developer Tools

Microsoft Visual Basic 2010 01018-532-2002102-70812
Microsoft Visual Basic 2010

Microsoft Visual C# 2010 01018-532-2002102-70812
Microsoft Visual C# 2010

Microsoft Visual C++ 2010 01018-532-2002102-70812
Microsoft Visual C++ 2010

Microsoft Visual F# 2010 01018-532-2002102-70812
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer 01018-532-2002102-70812
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010 01018-532-2002102-70812
Microsoft Visual Web Developer 2010

Crystal Reports Templates for Microsoft Visual Studio 2010
Crystal Reports Templates for Microsoft Visual Studio 2010

Hotfix for Microsoft Visual Studio 2010 Professional - ENU (KB2542054) KB2542054
This hotfix is for Microsoft Visual Studio 2010 Professional - ENU.
If you later install a more recent service pack, this hotfix will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/2542054.

Intel Visual Fortran Package ID: w_fcompxe_2011.7.258
Intel Visual Fortran Composer XE 2011 Update 7 Integration for
Microsoft Visual Studio* 2010, 12.1.3518.2010, Copyright (C) 2002-2011
Intel Corporation
* Other names and brands may be claimed as the property of others.

Microsoft Visual Studio 2010 SharePoint Developer Tools 10.0.30319
Microsoft Visual Studio 2010 SharePoint Developer Tools

Security Update for Microsoft Visual Studio 2010 Professional - ENU (KB2251489) KB2251489
This security update is for Microsoft Visual Studio 2010 Professional - ENU.
If you later install a more recent service pack, this security update will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/2251489.

The 4 DLLs is correct for VS 2010. Steve is updating the troublehouting article. Can you let me know if the workaround suggested works for you too.

Thanks,

------

Wendy

Attaching or including files in a post

After reading the troubleshooting page, I did a complete uninstall of both Update 7 and Update 4, then reinstalled Update 7. I got the same behavior. I opened the Solution file once with no issue. I opened it again, and got the same familiar "Visual Studio has caught an exception ..."

Also, I noticed that after updating to Update 7 whenever I open my solution file (i.e. everytime), Visual Studio (devenv.exe) pegs my CPU out for about 2.5-3 minutes while it (VS) says it is parsing (what seems to be) every single file in each of the projects contained in my solution. Now, each of these projects share a number of files, yet the files are parsed multiple times as they are encountered in each and every project. Opening my solution under Update 4 never took more than about 30 seconds, and the CPU was never pegged out for more than one or two continuous seconds.

I went to try and use Glenn's suggestion, but since this particular solution contains 9 seperate projects it is not as simple as just deleteing the *.sln file and opening the .vfproj file. I was able to open all of the *.vfproj files individually as projects without error, but as soon as I went back to opening the main .sln file, I got the error once again.

I've included images of the error popup, and the only error in the ActivityLog.xml file for you to see.

Attachments: 

AttachmentSize
Downloadimage/png VSActivityLogErr.png10.12 KB
Downloadimage/png VSerr.png6.7 KB

It looks like the IDE is getting registered which is what the troubleshooting article helps you determine. To try to find which part of the IDE is causing the issue can you set all of the options under Tools > Options > Text Editor > Fortran > Advanced > Browsing/Navigation to False and see what happens. Then selectively set one at a time (other than Disable Database) to True and see if one of them triggers the problem?

------

Wendy

Attaching or including files in a post

I am working on obtaining a fix I will send you both privately via email to test if you can.

------

Wendy

Attaching or including files in a post

Wendy, please let me know, as well, when you have found a fix.
I posted 3 Nov, regarding this error.

thanks

I will update this thread with the resolution. We are closing in on a fix. The two posters on this thread have tested 3 sets of DLLs from engineering. If you want to test the latest version of the fix please let me know and I can send you the DLL to try.

Wendy

We know have a fix for this error with 12.1 Update 7. If you are encounterring it please post to his thread and I will send you the DLL to try. We expect the fix will be in Update 8 of the compiler.

Hello Wendy,

I was not having this problem until I updated my VTune Amplifier XE to the update 6. Now I am getting the same error people have mentioned in this thread. Can I get the DLL fixes that you mentioned?

Thanks,
Jon

The fix should be in the Composer XE Update 8 just posted this week. Can you try installing it from registrationcenter.intel.com to see if it resolves the issue?

------

Wendy

Attaching or including files in a post

I have just installed Composer Update 8 on Windows 7 and am still getting the same exception described above. I have been closing the error message box and continuing without any apparent problems for the past several months, but would like to eliminate the error if possible. Any ideas?

Bill

Try this. Uninstall Fortran. Delete the "Intel Fortran" folder under Microsoft Visual Studio 10. Reinstall Fortran.

Steve - Intel Developer Support

Installing update 8, or uninstalling and re-installing IVF didn't help me in my case. The solution that I kept getting the error with had 8 Fortran projects. It turned out that some of the projects were created by VS 2005 they weren't converted to VS 2010 format. I opened each of the projects by themselves and converted to VS 2010. This solved my problem.

Jon

I uninstalled all fortran compilers, reinstalled only "w_fcompxe_novsshell_2011.8.278.exe" and still encounter the same exception message. The only thing that seems to prevent the exception from occurring in my case is to rename (or remove) the associated solution file (.sln) and then launch my project.I don't get the exception when I do this. I can then rename the solution back to the original name and launch without the exception occurring.

I have three projects each with an associated solution that has produuced the exception until I perform the steps I just mentioned above. The exception has not occurred again - yet.

Leave a Comment

Please sign in to add a comment. Not a member? Join today