Multi-processor compile option (/MP) not working

Multi-processor compile option (/MP) not working

I am using Intel Fortran XE 2011 on a Windows 7 64-bit machine in Microsoft Visual Studio 2010.The machine has an 8 core Intel i7 processor.When compiling MFC Visual C++ code I use the /MP compile option, which splits the compilation successfully over the 8 cores and results in a much faster compilation.I noticed in the Intel Fortran user guide that there is a similar option for Fortran compilation. However it appears to have no effect. Only 1 instance of ifort is ever created and the compile time is no different to when I was not using the /MP option.I know the /MP option is recognised by the compiler because when I tried using /mp instead it didn't recognise the option.Is there anything else I need to set to take advantage of the /MP option and the 8 cores available for compilation?Any help greatfully accepted, thanks.

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Someone from Intel will have to give you a formal answer but you might have some limited success with IVF and /MP by making multiple projects out of your code (even if it is one application). The projects can be different functional groups within the application. Your main (PROGRAM) project can then be made dependent on the other projects. VS now might be able to build each project in parallel. *** Note *** make (a) seperate modules project(s) that all code projects are dependent on. You may need to build this seperately (as you do not want each project to run the same build for the modules).

Earlier versions of IVF had issues of the compiler opening (input) source files for exclusive use (iow blocking the opening by another process running IVF from using the same file). This should have been fixed long ago and may very well have been fixed.

Jim Dempsey

Don't use the /MP option as it doesn't know how to deal with module dependencies. However, you can use the Vs ability to build projects in parallel, and this works fine.

Retired 12/31/2016

I am having the same problem when using IVF Compiler XE, both 32-bit and 64-bit, on Windows 7 Professional 64-bit. Is it still recommended not to use /MP ? It worked in previous versions of IVF Composer, but the latest version seems to ignore this parameter.

Last year we introduced a feature into Visual Studio to properly handle module dependencies with /MP. The problem now is that the /MP feature was unintentionally disabled for Fortran (but not Intel C++) in Update 2. I am working with the developers to see how quickly the feature can be restored. We apologize for the inconvenience.

Retired 12/31/2016

This will be fixed for Update 3.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today