.inp file

.inp file

I'm having trouble figuring out how to get intel fortran to skip the comment lines in my .inp file that's in my project. I tried putting "!" at the beginning of the lines and then "*" and "c". I can run the program with the input file correctly using a batch file outside of intel fortran. Is there something I can doto get it to skip the comment lines? Thanks!

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

This is a file that is read by the program? There is no such thing as comments in an input file from the Fortran perspective, except for NAMELIST input in which ! introduces a comment. A .inp file will not be compiled, even if added to the project, unless you specified that .inp is a Fortran source file extension in Tools > Options > Intel Visual Fortran > General.

Some more detail as to what you are doing would be helpful.

Retired 12/31/2016

That answers my question, actually. Thank you!

So prof Steve,does the fact that,based on your above answer that the .INP will not be compiled unless if it is specified that  the .INP is a Fortran source file extension pose any issue to running the program afterwards?.What I meant to say is,will the program still run as expected if the .INP extension is not specified,or it just need be specified before it could run?

Thank you.

Based on your other posts - that file is not a Fortran source file.  That is an input file for the Aspen Plus program itself.

Leave a Comment

Please sign in to add a comment. Not a member? Join today