The breakpoint will not currently be hit. No symbols have been loaded for this document.

The breakpoint will not currently be hit. No symbols have been loaded for this document.

Hi,I need some help with this problem which appeared when i am trying to debug my code in Visual 2008 and fortran 11.1; the breakpoint are ignored and they appears with a exclamation symbol. When I position the cursor of mouse on this the next message can be read:"The breakpoint will not currently be hit. No symbols have been loaded for this document."In the properties of the project in the debugging option I have select:Command: $(TargetPath).Attach: No.Merge Environment: Yes.Debugger Type: Native Only.Conecction: Local.And in the Fortran Debugging.Debug Information Format: Full(/debug:full).Sorry for my english and for the basic of my question, but I can't debug my actual project. Past Project can be debug, but the project that i create now, no.Thanks.

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I improve the solution in past post for similar problem, but anything them work. I don't have problem in debugging code which i Have released in CVF, but the actual project in IVF i can't debugging.

The usual reason for this is that the EXE or DLL you are running is not the one built from the project.

Retired 12/31/2016

Sorry Steve, but, how can i review if the EXE or DLL that I am running is the one built from the project?. When I am running the project without debugging, the program don't have any problem, and when I am running for debugging, the breakpoint are ignored. Sorry for the inconvenience, but I need to learn how to use better the debugger.Thank you for your first answer.

check under Project / Properties / Debugging.

the Command field should be pointing to your executable - mine shows $(TargetPath)

If this is hardcoded to another path, then you are not running theexecutable you have compiled.



Sometimes when I experience a problem similar to yours of placing a break point in a source module, I find that I can place a break point in some source file that calls the function/subroutine of interest. Then by stepping into the function/subroutine (assuming it steps into) will expose which file is being called. Sometimes it is a case of you having the wrong file open in your IDE session.

If the debugger will not step into the function/subroutine then this is usually the result of what is being called either does not have debug symbols or the source file (usually DLL) cannot be ascertained until after it is called. In this case, when you reach the break point in the caller, open a dissassembly window (note you may receive cannot display... - ignore this), then press F11 (Step Into) until the call completes. When you get into what was called, the source window should identify the file. This will likely not be the file you thought it was.

Note, if this is a first call of a DLL then you may be entering the DLL loader instead of the DLL which will make debugging difficult. In this case, insert a benign call to the "same"DLL just in front of the call in the outer source file. This should load the DLL and populate the dispatch vectors, and then the step into should reach the now loaded DLL. If you still reach the DLL loader instead of the DLL then the benign call is calling a different DLL than what you expected. i.e. you have a library viersioning issue (Window SBS is loading different version of "same named" DLL).

Jim Dempsey

Thanks gentlemen for your responses.

I have succesfully debugged my IVF dll in both Excel and Mathamatica (net/link). But today, and at various other times, I get the messages.

"The breakpoint will not currently be hit. No symbols have been loaded for this document" next to an incomplete debug F9) point .. and I cannot debug it. Very frustrating!

 This  problem is identical in w_cprof_p_11.0.072_ia32 (where it was fine all last week) and my" brand new" w_fcompxe_novsshell_2013.1.119".  Obviously I am doing something different!

  1.  am running the correct DLL (e.g. that one cannot then be deleted)
  2.  I have disabled optimization
  3. I have gutted the debug dir and tried again


  /OUT:"Debug\Lexus01031.dll" /NOLOGO /LIBPATH:"C:\Program Files\Intel\MKL\\ia32\lib" /MANIFEST /MANIFESTFILE:"C:\Users\psa\Documents\Laplacian\Lexus\lexus2005\Lexus01031\Debug\Lexus01031.dll.intermediate.manifest" /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /DEBUG /PDB:"C:\Users\psa\Documents\Laplacian\Lexus\lexus2005\Lexus01031\Debug\Lexus01031.pdb" /SUBSYSTEM:WINDOWS /IMPLIB:"C:\Users\psa\Documents\Laplacian\Lexus\lexus2005\Lexus01031\Debug\Lexus01031.lib" /DLL /qnoipo mkl_c.lib libguide.lib

  •  Are there any more obvious things to try?
  •  If necessary is there a "dump" I can attach that contains the essence.. without all my source code?

Should I have put this question here or elsewhere?

Thanks Peter



Peter, I'm also trying to debug Mathematica (.NET/Link using DefinDLLFunction) and IVF. I tried attaching to InstallableNET but can't get code to attach. Did you solve this?

[EDIT] the attach options kept switching to managed. Once I switched it off "Automatic" and manually set Native, it attached.

Leave a Comment

Please sign in to add a comment. Not a member? Join today