insufficient virtual memory

insufficient virtual memory

Dear all,

I am running a program with Fortran OpenMP. I got this message:

"insufficient virtual memory".

My machine has 24GB, 12 threads. I am not
sure whether this is really about memory. Thanks for hints.

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

24 GB is a lot of RAM, and it is possible that the configuration allows virtual memory in excess of that, if you have enabled that feature.

However, 24 GB is less than infinite memory. Therefore, you have to investigate what demands are being made by your program, and what the operating system is configured to allow.

Thanks. Can you be more specific as to how I can check the configuration. and how i can change it if necessary?

I'd suggest that you look first at obtaining a good estimate of what your program requires in terms of statically and dynamically allocated memory, the type of OS that you are running, and the size of your pagefile.

If you are running a 32-bit OS, be aware that there is the upper limit of allocatable memory for programs is 4 GB, which needs to be adjusted down by the needs of the OS itself, drivers, etc., and any limitations imposed by the compiler/linker that you use.

Also if you are running on 64-bit platform,check to see if you are compiling and running a 32-bit application. When you create a new solution on Windows x64 platform it defaults to Win32 32-bit. Use configuration manager to create the x64 platform projects.

Jim Dempsey

www.quickthreadprogramming.com

I am not sure whether the following info would be useful. (sorry for my ignorance about computers)
I have a 64-bit Windows 7. Dual Six Core Intel Xeon Processor.

In Visual Studio, open your solution/project and look to the right of where you select Debug/Release, this is the platform selector. If the pull-down reads Win32 then you are generating a 32-bit Windows application. If you see Win32, then click on platform pull down and select x64 if it is listed or click on "Configuration Manager" if it is not. If you had to select "Configuration Manager" then on the top right side you will see a pull down listed as "Active solution platform", pull that down and select "New", then fish around for x64. Also choose new configuration to be based on your Win32 configuration. Then finish the dialogs saving the new configuration. When you get back to the IDE you will now see x64 in the platform pull down. From now on, you can select which platform Win32/x64 for this solution.

Jim Dempsey

www.quickthreadprogramming.com

Somehow, after I did that, I cannot compile / build my solution. I got the message:
"internal compiler error C000094" "compilation aborted"
I tried the same with another project, it works there.
What is wrong with the current project? Thanks

Read the compiler output window to see why the compilation aborted. If nothing obvious shows up, then in the compiler output window locate the line that says "Build log was saved at...\BuildLog.htm"
Put the mouse over that line and issue Ctrl-Click. This will open the build log.

In there you will see additional error messages.

Compilation aborted is generally a result of not specifying a path or not installing a component.

When you installed the Intel Fortran compiler, did you install both the 32-bit and 64-bit compilers?
Your download options are for

1) both versions
2) 32-bit version
3) 64-bit version

Note use Intel64 not IA64 (IA64 is for Itanium processor)

Jim Dempsey

www.quickthreadprogramming.com

Here is what I get from the log, ( I believe I installed Intel64. Another project went fine with X64. )

Compiling with Intel Visual Fortran 11.1.065 [Intel 64]...
ifort /nologo /debug:full /Od /gen-interfaces /Qopenmp /warn:interfaces /module:"x64\Debug\" /object:"x64\Debug\" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc9 /Qlocation,link,"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64" "C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\Emax.f90"
fortcom: Fatal: There has been an internal compiler error (C0000094).
compilation aborted for C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\Emax.f90 (code 1)

ifort /nologo /debug:full /Od /gen-interfaces /Qopenmp /warn:interfaces /module:"x64\Debug\" /object:"x64\Debug\" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc9 /Qlocation,link,"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64" "C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\dynamics.f90"
fortcom: Fatal: There has been an internal compiler error (C0000094).
compilation aborted for C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\dynamics.f90 (code 1)

ifort /nologo /debug:full /Od /gen-interfaces /Qopenmp /warn:interfaces /module:"x64\Debug\" /object:"x64\Debug\" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc9 /Qlocation,link,"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64" "C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\moments.f90"
fortcom: Fatal: There has been an internal compiler error (C0000094).
compilation aborted for C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\moments.f90 (code 1)

ifort /nologo /debug:full /Od /gen-interfaces /Qopenmp /warn:interfaces /module:"x64\Debug\" /object:"x64\Debug\" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc9 /Qlocation,link,"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64" "C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\GMM.f90"
fortcom: Fatal: There has been an internal compiler error (C0000094).
compilation aborted for C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\GMM.f90 (code 1)

ifort /nologo /debug:full /Od /gen-interfaces /Qopenmp /warn:interfaces /module:"x64\Debug\" /object:"x64\Debug\" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc9 /Qlocation,link,"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64" "C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\simulation.f90"
fortcom: Fatal: There has been an internal compiler error (C0000094).
compilation aborted for C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\simulation.f90 (code 1)

ifort /nologo /debug:full /Od /gen-interfaces /Qopenmp /warn:interfaces /module:"x64\Debug\" /object:"x64\Debug\" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc9 /Qlocation,link,"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64" "C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\main.f90"
fortcom: Fatal: There has been an internal compiler error (C0000094).
compilation aborted for C:\Users\cfu\Documents\My Research\Taxi Driver\New Sept26_10\New Sept26_10\main.f90 (code 1)


New Sept26_10 - 6 error(s), 0 warning(s)

Suggest going google search
"fortcom: Fatal: There has been an internal compiler error (C0000094)" site:intel.com

Example:

http://software.intel.com/en-us/forums/showthread.php?t=67498

Look at reply #3 and later (read all)

Jim Dempsey

www.quickthreadprogramming.com

Thanks. That seems to have solved the problem.

Leave a Comment

Please sign in to add a comment. Not a member? Join today