Text editor doesn't recognize fixed-form source

Text editor doesn't recognize fixed-form source

Moved discussion from 11.1 announcement thread

Retired 12/31/2016
38 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

After installing 11.1, Visual Studio no longer seems to recognize lines starting with 'C' as comments or lines with a character in column 6 as continuation lines in the "Fonts and Colors" settings. Maybe a subtle nudge to get us away from old Fortran 77 code?

It works for me - what is the file type?

Retired 12/31/2016

Quoting - Steve Lionel (Intel)
It works for me - what is the file type?

It is a Fortran file with a .f extension. Comments using the '!' are colored properly, just not the old-fashioned kind.

To the original poster,

How do I upgrade to 11.1 without starting over again ? I have to go throughtatleast anhour downloading and installing the latest version. Any workarounds for that??


Go to Tools > Options > Intel Fortran > General. Is .f listed under Fixed Format Source?

Retired 12/31/2016

Quoting - Steve Lionel (Intel)


Go to Tools > Options > Intel Fortran > General. Is .f listed under Fixed Format Source?

Here is what I see:

Curious. Try an uninstall and reinstall.

Retired 12/31/2016

That should not happen .
Try .for or .FOR instead; .FOR works for me as well as .f for FIXED FORMAT !

Quoting - Peter

That should not happen .
Try .for or .FOR instead; .FOR works for me as well as .f for FIXED FORMAT !

Look for unintentional/free /FR or/4Yf property or ifort.cfg setting.

Quoting - tim18

Look for unintentional/free /FR or/4Yf property or ifort.cfg setting.

Tim, the text editor doesn't know about those things.

Retired 12/31/2016


I am also seeing this problem. I haven't tried to uninstall/reinstall but that shouldn't be required.

Abhi

Quoting - abhimodak


I am also seeing this problem. I haven't tried to uninstall/reinstall but that shouldn't be required.

Abhi

I don't see why it should happen ! But you never know what's going on !
Did you guys custom install ??

For those of you seeing this problem, which Visual Studio version were you using before and which are you using now? Does it do this for only .f files or for also .for files?

Open up a Windows Explorer directory window, select Tools > Folder Options > File Types (this is for XP - instructions for Vista are slightly different). Scroll down to the entry for file extension F. What does it say the File Type is?

Retired 12/31/2016

Quoting - Steve Lionel (Intel)
For those of you seeing this problem, which Visual Studio version were you using before and which are you using now? Does it do this for only .f files or for also .for files?

Open up a Windows Explorer directory window, select Tools > Folder Options > File Types (this is for XP - instructions for Vista are slightly different). Scroll down to the entry for file extension F. What does it say the File Type is?

Uninstalling and reinstalling did not help. I did the full installation, not custom.

I am using VS2005, both before and after installing IVF11.1.

Files with extensions .f, .for, and .F90 all show up as "Fortran Source" in the type column of the detailed view of the explorer window (Vista). A file with the .F extension is also listed as "Fortran Source" in the file properties window.

Microsoft Visual Studio 2005
Version 8.0.50727.867 (vsvista.050727-8600)
Microsoft .NET Framework
Version 2.0.50727 SP2

Installed Edition: Standard

Microsoft Visual C++ 2005 77633-235-1531756-41204
Microsoft Visual C++ 2005

Microsoft Web Application Projects 2005 77633-235-1531756-41204
Microsoft Web Application Projects 2005
Version 8.0.50727.867

Intel Visual Fortran Compiler Integration Package ID: w_cprof_p_11.1.035
Intel Visual Fortran Compiler Integration for Microsoft Visual Studio* 2005, 11.1.3462.2005, Copyright (C) 2002-2009 Intel Corporation
* Other names and brands may be claimed as the property of others.

Microsoft Visual Studio 2005 Standard Edition - ENU Service Pack 1 (KB926601)
This service pack is for Microsoft Visual Studio 2005 Standard Edition - ENU.
If you later install a more recent service pack, this service pack will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/926601

Security Update for Microsoft Visual Studio 2005 Standard Edition - ENU (KB947738)
This Security Update is for Microsoft Visual Studio 2005 Standard Edition - ENU.
If you later install a more recent service pack, this Security Update will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/947738

Update for Microsoft Visual Studio 2005 Standard Edition - ENU (KB932232)
This Update is for Microsoft Visual Studio 2005 Standard Edition - ENU.
If you later install a more recent service pack, this Update will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/932232

Quoting - a.leonard
Uninstalling and reinstalling did not help. I did the full installation, not custom.

I am using VS2005, both before and after installing IVF11.1.

Files with extensions .f, .for, and .F90 all show up as "Fortran Source" in the type column of the detailed view of the explorer window (Vista). A file with the .F extension is also listed as "Fortran Source" in the file properties window.

Microsoft Visual Studio 2005
Version 8.0.50727.867 (vsvista.050727-8600)
Microsoft .NET Framework
Version 2.0.50727 SP2

Installed Edition: Standard

Microsoft Visual C++ 2005 77633-235-1531756-41204
Microsoft Visual C++ 2005

Microsoft Web Application Projects 2005 77633-235-1531756-41204
Microsoft Web Application Projects 2005
Version 8.0.50727.867

Intel Visual Fortran Compiler Integration Package ID: w_cprof_p_11.1.035
Intel Visual Fortran Compiler Integration for Microsoft Visual Studio* 2005, 11.1.3462.2005, Copyright (C) 2002-2009 Intel Corporation
* Other names and brands may be claimed as the property of others.

Microsoft Visual Studio 2005 Standard Edition - ENU Service Pack 1 (KB926601)
This service pack is for Microsoft Visual Studio 2005 Standard Edition - ENU.
If you later install a more recent service pack, this service pack will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/926601

Security Update for Microsoft Visual Studio 2005 Standard Edition - ENU (KB947738)
This Security Update is for Microsoft Visual Studio 2005 Standard Edition - ENU.
If you later install a more recent service pack, this Security Update will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/947738

Update for Microsoft Visual Studio 2005 Standard Edition - ENU (KB932232)
This Update is for Microsoft Visual Studio 2005 Standard Edition - ENU.
If you later install a more recent service pack, this Update will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/932232

the latest version(ivf 11.1) comes with ms visual studio 2008 shell version. are you not using it? but i dont know if it makes any difference. !

Quoting - Peter
the latest version(ivf 11.1) comes with ms visual studio 2008 shell version. are you not using it? but i dont know if it makes any difference. !

If he already has the full VS2005, there would be no reason to use the VS2008 Shell and it is not installed.

Others who are seeing this - which VS version are you using?

Retired 12/31/2016

My apologies for the delay in responding back.

I was and am using VS 2005 on XP64.

In the File types, F appeared as a visual studio file while F90 as fortran source. For F extension there is an option to "restore" to fortran source. Then I closed and opened the visual studio but still the problem remains.

Abhi

Ok, let's try this. For those of you using VS2005, save the attached file and double-click on it to edit the registry. If you are using a different VS version, do not use this file. (You can edit it and change the 8.0 to 9.0 or 7.1 for VS2008/VS2003 if you wish.) Restart Visual Studio and see if the problem persists. This is just a random idea of mine - I have a request in to the IDE developers for their thoughts.

Attachments: 

AttachmentSize
Downloadapplication/octet-stream Fixed.reg802 bytes
Retired 12/31/2016

Here's something interesting. If I open the file from File menu or the Solution Explorer window, the text editor is OK. If I open it by double-clicking on a line in the Find Results or Error List windows, it is not. When I close the solution and reopen it, it is not OK anymore, even if it was before.

I think it was like this before the registry change in the previous post. It is definitely like that now.

Use of the registry edit does not help either.

Abhi

Ok- I didn't think it would but it was worth a shot. Let me see what the IDE developers suggest.

Retired 12/31/2016

The developers got back to me. They say that they know about this issue and that it is not new, though some change may have revealed it for you. The problem can occur when:

  • You try to open a file without a project open and you open the file from the Errors or Find Result pane.
  • The file does not belong to the current (active) project

I will ask that this be fixed in a future update.

Retired 12/31/2016

Quoting - Steve Lionel (Intel)
The developers got back to me. They say that they know about this issue and that it is not new, though some change may have revealed it for you. The problem can occur when:

  • You try to open a file without a project open and you open the file from the Errors or Find Result pane.
  • The file does not belong to the current (active) project

I will ask that this be fixed in a future update.

What do you mean by "current (active) project"? Is the active project the one that contains the file currently "active" in the text editor. If so, that agrees with what I observe. It never happened to me before I installed 11.1, however.

I have a solution with 47 projects, so it's very likely that opening a file from the Find Results pane will not open a file in the active project.

I'll admit that wording had me a bit confused -not sure what he meant by that. But it does sound as if this mostly explains what you are seeing. It will get fixed.

Retired 12/31/2016

Quoting - Steve Lionel (Intel)
Ok, let's try this. For those of you using VS2005, save the attached file and double-click on it to edit the registry. If you are using a different VS version, do not use this file. (You can edit it and change the 8.0 to 9.0 or 7.1 for VS2008/VS2003 if you wish.) Restart Visual Studio and see if the problem persists. This is just a random idea of mine - I have a request in to the IDE developers for their thoughts.

Can I undo this? Visual SourceSafe doesn't seem to know to use VisualStudio to edit .F files anymore.

Undo what - the registry file I sent? that just sets what should be set.

Go into the File Types list as I described earlier, select the F extension and click the Change button by Opens With. Select the desired Visual Studio.

Retired 12/31/2016

Steve

Reverting back to visual studio in tools--file options does not help. VSS does not recognize F extension. I must be doing something wrong here.

Is there any work around or we are forced to wait for a "patch"? May be it is worth making a point (I apologize for rude words here) that a text editor is quite essential component. Already the IVF text editor lacks many features and that has been blamed on microsoft making too many changes. While I think I understand that I would say that at least keeping the current simple editor intact should be made a part of testing.

Abhi

Abhi,

The editor seems to work fine for most people, and we never had a complaint about this during our beta test that I am aware of. I don't know what causes it to fail for you. As for VSS, I don't know what it uses - it should simply be using the file association set in File Types. Can you double-click on a .F file and bring up Visual Studio?

If you want to try to "reset" everything, remove the Intel Visual Studio integration. Delete the registry entries for HKEY_CLASSES_ROOT.f and HKEY_CLASSES_ROOT.for, then reinstall the integration.

Retired 12/31/2016

Thanks Steve. ".F" does open in visual studio when I double click on it in the windows explorer.

I will do the registry thing you mentioned.

One dumb question: when installing the 11.1 it displays an info-box saying that with new (11.1) integration the old one with v10 will not be possible. However I can still build and run with 10.1.024 through Visual Studio. May be I did not understand it right or is there something here? Does it mean that I don't have 11.1 integration?

Since you say that this text editor problem is my local issue I thought of reporting this.

Abhi

Quoting - Steve Lionel (Intel)
Abhi,

The editor seems to work fine for most people, and we never had a complaint about this during our beta test that I am aware of. I don't know what causes it to fail for you. As for VSS, I don't know what it uses - it should simply be using the file association set in File Types. Can you double-click on a .F file and bring up Visual Studio?

If you want to try to "reset" everything, remove the Intel Visual Studio integration. Delete the registry entries for HKEY_CLASSES_ROOT.f and HKEY_CLASSES_ROOT.for, then reinstall the integration.

I changed the entry back to "VisualStudio.Fortran.8.0" and VSS opens the files correctly. I didn't have to do anything with the installation.

If you see 11.1 or as a choice for compiler, you have 11.1. I think it is 10.0 you can't use with the new integration, but I'm not certain of that.

Retired 12/31/2016

I believe that this problem was fixed in update 2 (11.1.046). Please try that and let me know.

Retired 12/31/2016

Quoting - Steve Lionel (Intel)
I believe that this problem was fixed in update 2 (11.1.046). Please try that and let me know.

Hi Steve

As of today (:)) it is working for me...

Abhi
I may be wrong here but I think it started to work when I installed the previous (July upgrade) 11.1.038.

Quoting - Steve Lionel (Intel)
I believe that this problem was fixed in update 2 (11.1.046). Please try that and let me know.

Apparently not, since my issue with Premier (555791) is still open.

I've only tried it onVS2008 SP1 STD/Win2008x64.

If I have a few .FOR files open, I exit VS (the X in thetitle bar), openthe solutionagain - the files that were previously open come up with screwy colors.

I can't reproduce that. I looked at your Premier issue and tried following the steps you indicated, but it all worked ok for me.

Retired 12/31/2016

Quoting - Steve Lionel (Intel)

I can't reproduce that. I looked at your Premier issue and tried following the steps you indicated, but it all worked ok for me.

The sequence from that issue was with the old version of 11.1 compiler. The sequence I described above could be a brand new bug.

I tried the above sequence too and did not see a problem.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today