.f95 files in VS IDE

.f95 files in VS IDE

I am evaluating the latest Intel Fortran Compiler in the VS 2005 IDE. I can't compile my project consisting of several dozen *.f95 files.

I tried Tools>Options>Fortran>General and added .f95 and restarted VS. No effect:

Warning 1 command line warning #10161: unrecognized source type 'E:\TimDocs\fort\fft_auto\source\q2imask_module.f95'; object file assumed ifort

Based on a thread here, I tried Project>Properties>Fortran>Command Line and added /extfor:.f95. ifort now tries to compile, but apparently doesn't recognize the file content:

module q2imask_module
contains

subroutine q2imask(qmask,imask,li)

...

Generated errors on every character:

Error 1 error #5149: Illegal character in statement label field [m] E:\TimDocs\fort\fft_auto\source\q2imask_module.f95 1
Error 2 error #5149: Illegal character in statement label field [o] E:\TimDocs\fort\fft_auto\source\q2imask_module.f95 1
Error 3 error #5149: Illegal character in statement label field [d] E:\TimDocs\fort\fft_auto\source\q2imask_module.f95 1

Any help?

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

This is a known problem and should be fixed in a future update. All I can suggest is what I would normally recommend - do not use .f95, .f03 or other non-industry-standard file type. It is a common misconception that the file type designates the standards revision level. All it does is distinguish free-form from fixed-form source. Please use the .f90 file type for your free-form source. Our issue ID is DPD200049917.

A possible workaround is to add the command line option /free to Additional Options under Command Line.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today