PRJ0019 Error

PRJ0019 Error

Hi there, i did some search about this issue, but there seems nothing
can solve my problem. I'm running windows vista and vs2005 as administrator.
This is my output log:
Compiling with Intel Fortran Compiler 10.1.011 [IA-32]...
ifort /nologo /Zi /Od /gen-interfaces /warn:interfaces /module:"Debug" /object:"Debug" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc8 /Qlocation,link,"C:Program FilesMicrosoft Visual Studio 8VCin" "C:UsersHyouhakuDocumentsVisual Studio 2005ProjectsAssign1Assign1Assign1.f90"
Link /OUT:"DebugAssign1.exe" /INCREMENTAL:NO /NOLOGO /MANIFEST /MANIFESTFILE:"C:UsersHyouhakuDocumentsVisual Studio 2005ProjectsAssign1Assign1debugassign1.exe.intermediate.manifest" /DEBUG /PDB:"C:UsersHyouhakuDocumentsVisual Studio 2005ProjectsAssign1Assign1debugassign1.pdb" /SUBSYSTEM:CONSOLE "DebugAssign1.obj"
Link: executing 'link'

Embedding manifest...
mt.exe /nologo /outputresource:"C:UsersHyouhakuDocumentsVisual Studio 2005ProjectsAssign1Assign1debugassign1.exe;#1" /manifest "C:UsersHyouhakuDocumentsVisual Studio 2005ProjectsAssign1Assign1debugassign1.exe.intermediate.manifest"
Assign1 : error PRJ0019: A tool returned an error code

Assign1 - 1 error(s), 0 warning(s)
4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

This seems to be one of those annoying VS problems that "just happens".
I have some batch files which I run to build our libs and exes, and every
now and again (ie yesterday and this morning) thereare some projects
which fail with this PRJ0019 error. I have found that by opening the
projects individually in Visual Studio and building them one at a time,
the build is then successful.

Sometimes (not often) the error occurs in VS when building an individual
project. Doing a REbuild usually fixes it.


Thanks Les, that's exactly the problem. yes sometime it works, but hasn't the intel team found a solution? it's really annoying

The cases we have seen have one of the tools (such as rc) actually fail, with the fail message in the build log. Or sometimes you have to do the command manually to see what the error is and then fix it.

I have never seen this happen from the manifest tool. I am not familiar with an intermittent problem as Les describes.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today