Visual Studio crashing when loading fortran fixed code VF2013

Visual Studio crashing when loading fortran fixed code VF2013

Since I've installed Visual Fortran 2013, many .f (fixed) Fortran source files cause VS2010 (and 2012) crash on load. To isolate the problem, I tried loading just single source files (no projext or solution) with exactly the same results. VS crash on file load.

I've installed VS2012 + Visual Fortran 2013 from scratch on a second system with clean installed Win7 and the problem persists. BTW previous Visual Fortran version (2011) works fine with no crashes at'all.

.f files that crash the VS environment are NEC2 and NEC4 sources if that helps.

Any idea?

24 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Can you supply us with the source files that cause the problem?

Steve - Intel Developer Support

I cannot post the files publicly; Could you please give me an email address to pass them over to you?


Please use Intel Premier Support to submit the issue, then.

Steve - Intel Developer Support

I'm trying to access the premier support site but I'm getting this error page.

I can't see your email address so I don't know what you have support registered for. If you want, you can click on the "Send Author A Message" link and attach a file there. That won't be public, though it is not as secure as using Premier Support. Please do also follow the instructions on that error page for resolving your access issue.

Steve - Intel Developer Support

Message and attached .f file sent.

Thanks Steve!

Thanks - I can reproduce the problem and will report it to the developers. As a workaround, go to Tools > Options > Text Editor > Fortran > Advanced and set Disable Database to True. Issue ID is DPD200236601.

Steve - Intel Developer Support

Thanks Steve for acknowledging the bug.

BTW the "database disable" workaround doesn't seem to be working consistently. After loading my solution and opened an .f source file VS2012 crashed.

Anyway, I hope Intel Fortran developers will get this fixed soon.

You probably have to restart VS to see the change. The workaround worked for me.

Steve - Intel Developer Support

Hmm I did that but still crashed after loaded the solution.

This has been fixed for Update 2, which I think is scheduled for January. The workaround is to not split Hollerith constants across lines.

Steve - Intel Developer Support

I got the same problem. The work around doesn't help.

Please attach a ZIP of a file that gives you the problem.

Steve - Intel Developer Support


Thanks for the source. The cause of this problem is an operator, (.LT. in this case) being split across lines - apparently the VS parser doesn't like this. I will escalate it. The issue ID is DPD200238036.

The workaround is to edit lines 235, 241, 248 and 254, where the lines end with .LT Remove one of the leading blanks from those lines and add a dot at the end, deleting the one at the beginning of the next line, so the .LT. is entirely contained in one line.

Steve - Intel Developer Support

It works. Thanks a lot

I have been told that this new problem is fixed for Update 2., due late January.

Steve - Intel Developer Support

Hey heeyyyyy! The work-around (Disable Database) fixed my problem!

Thanks guys :)

BTW, I'm running with a compiler where the install file says "13.2.049" but the compiler header says "". So, either the problem is not fixed in update 2; I'm not running on update 2; or there is another similar issue with the parser for the database!

(My crash message in the event viewer was:
Application: devenv.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at Intel.Fortran.UnionDataBase.FortranMatch+<>c__DisplayClass3.<Name>b__2(Intel.Fortran.UnionDataBase.FortranSymbol)
   at System.Linq.Enumerable+WhereSelectListIterator`2[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]].MoveNext()

Can you attach the source file that triggers the problem? Right now the only issue I know of is if you have INTERFACE OPERATOR (=) in some contexts.

Steve - Intel Developer Support

Yes I've sent it (as a reply to the email).

If you mean an email that Intel Developer Zone sent you to notify you of a reply, that won't be delivered.  Use the file attachment tool below or you can attach it to a private message you send me.

Steve - Intel Developer Support

Ah! Whoops. Ok, attached now. Let me know if it's not enough.



Downloadapplication/zip rangetype.zip1.3 KB

Yes, it's the INTERFACE OPERATOR declarations. Turning off Tools > Options > Text Editor > Fortran > Advanced > Collect Object Browser Information is a workaround for now. Our developers are already working to fix this. I will let you know of any progress.

Steve - Intel Developer Support

Ok. Thanks Steve.

Cheers, Geoff

Leave a Comment

Please sign in to add a comment. Not a member? Join today