"Object reference not set to instance of an object" ????

"Object reference not set to instance of an object" ????

I sent this before on 9/12, with a screen shot attached.

No one ever responded -

Anyway, it only occurred after I downloaded the new Fortran.

It happens when I try to modify the source code while still debugging.

I thought that was permissible (?)

In other words, if I stop debugging, I CAN modify the source code OK.

In previous versions, that never happened. So there is now some (unwanted) interaction between the source code

editor and the debugger that didn't occur before.

Sometimes it just crashes with an exception.

On the other CPU, I still have the older Fortran, it does not ever happen there.

 Is this something you don't want to dscuss?

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If you can find a way to reliably reproduce it, we'll look into it. Your post before was rather ambiguous about what you were seeing.

Steve - Intel Developer Support

This may have to do with Visual Studio Intelisense integration with the VS Debugger.
Try temporarrily disabling VS Intelisense to see if the problem goes away.
This will help isolate the problem, and may lead to earlier resolution.

Jim Dempsey

www.quickthreadprogramming.com

How do I turn that off?
could not find anything about that anywhere.

I can't be "reliable" because it does not always do it.
Just because it's an intermittent problem,
is that a reason to ignore it?
I sent a screen snapshot. Is that ambiguous?

Here is another screen shot. It's a JPEG file.
This happens fairly often.
You can see where I am trying to insert code after line 6.
I get that every time.
I do not get that when i DELETE code however.

Attachments: 

AttachmentSize
Downloadimage/jpeg vs-bug.jpg282.88 KB

I have the same problem popping up sporadically - as billsincl notes, it occurs when I try to edit the code while it is still in debug mode.

Thanks for the screenshot and the confirmation that this happens during debugging. I have escalated this to development as issue DPD200236858. I know that they have fixed a different problem with editing while debugging in the upcoming Update 1, so that might (perhaps) also fix this. I will let you know what I hear from the developers.

You might try, as a workaround, setting options under Tools > Options > Text Editor > Fortran > Advanced to False. I would start with the choices under Intrinsics, Miscellaneous and Outlining.

Steve - Intel Developer Support

The developers tell me that they have fixed this for Update 1, due sometime this month.

Steve - Intel Developer Support

Verifying that it was fixed.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today