Source file parsing takes long time

Source file parsing takes long time


After upgrading to Composer 13, I have encountered quite a few issues. Here are a few that are more annoying than others:

(1) For a big file (with more than 30,000 lines), if I start typing something I see in the bottom left corner of the VS that "parsing file" is going on. See the attached picture. It takes a long time for it to finish. (I can keep typing without seeing what is being typed. Eventually, all the text does appear.)

(2) Syntax coloring is lost in debug mode. I see that this has been reported; hoping to see it fixed in update 1.

(3) I am also seeing that when running program with debug (in Visual Studio), it takes a long time for it to arrive at the first break-point. In the bottom left corner I see that it is loading c:\windows\ *.dll. I have already set _NO_DEBUG_HEAP=1 through VS properties window. In some cases when I removed all the debug break points this issue went away. Note that I had exactly same number of breakpoints in the project before upgrading to XE13 and there was no such issue.

(4) Lastly, as everyone is seeing, this forum's new design is really something one has to learn to live with.



Downloadimage/png parsingerror.png745 bytes
4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

(1) is annoying (there have to be opportunities for optimisation of the parsing process - for example when I type in a comment context why does parsing need to happen at all...) but you can manage it by turning off the source code browsing features.

(3) may be due to symbol loading issues. What are your symbol loading settings? You can specify that you don't want symbols to be loaded for common operating system DLL's.

Hi IanH

Thanks for your comment on (3). Can you tell me where and what should I specify? I did not have to do this before XE13.


(This may well not be the cause of the delay you see on starting debugging and it is not something that I'd expect to suddenly change with ifort version - it is just something to consider. Certainly, if symbol settings are out of whack (say the symbols are being downloaded from microsoft each time you start debugging or the debugger is looking for symbols on non-existent network shares or similar silliness) then debugger start up times can become rather excessive.)

Tools > Options, then Debugging > Symbols. You can then click "Specify excluded modules" and list away. While you are in that tab in the options dialog check the cache location to make sure it is sane.

Alternatively, while debugging you can right click on a module in the Modules view (Debug > Windows > Modules) and select Automatic Symbol Load Settings > Always Load Manually to have the DLL added to that excluded list.

(Don't add modules associated with your source code or debugging will become ... tricky.)

Leave a Comment

Please sign in to add a comment. Not a member? Join today