Optimization and OpenMp

Optimization and OpenMp


I have big program in Fortran.

when I tried to run the program in Release mode with -O2 and Qopenmp it works wrong. I can not trace it because in Debug mode it works fine with both O2 and Qopenmp. There are not openmp directives in the program now.

If works fine with only O2 (optimization) and very fast. It works fine with only Qopenmp. 

It is IVF Composer 2011, IA-32, WIn 2008; it is  a Console appl. 

O2 I set from: Project properties/Fortran/Optimization/Maximize speed. 

Qopenmp set by: Project Properties/Language/ Process OpenMP directives/Generate parallel code.

I tried to recompile with dynamic libraries: Project properties/Labraries/ Debug Multithread DDL,

But it has no effect. Heap and stack reserve and commit size are 0.




2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

For OpenMP you have available diagnostic tools such as Inspector, or you can add or remove parallelization incrementally, if you're having difficulty locating the error.
You should be able to add -O2 to your debug options and get the same behavior as without debug.

Leave a Comment

Please sign in to add a comment. Not a member? Join today