right-click to open included file

right-click to open included file

In past versions of Visual Studio (sorry, I can't recall which) it was possible to have a .F file open, then right-click an INCLUDEd file and be given the option to open the include file, assuming it could be located. I found an old thread that refers to this, but I doesn't work in VS 2010 SLN files that I have built by hand; nor in those built by Cmake. This occurs even if the INCLUDE file (.F77 suffix) is explicitly put in a "Header Files" section. The Error dialog reports "Object reference not set to an instance of an object." The include path is valid and the projects build and run normally. In this mixed-language solution, the include (.h) files associated with the C-language portions all work correctly.

Using my current version (VS10.0.40219 SP1Rel) I was unable to find a way to add this through any Tools>Options>Text Editor>Fortran or Tools>Options>Intel Visual Fortran options.

Is this a feature I should be able to make work?

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I just tried it myself and it does work. I am using Intel Visual Fortran Composer XE 2013 Update 1.

Retired 12/31/2016

Sorry: I should have added this information: I'm using Intel(R) Visual Fortran Composer XE 2011 Update 8 Integration for Microsoft Visual Studio* 2010, 12.1.3520.2010. Any idea if it doesn't work in my version? Is is a feature that the user can somehow disable?

I vaguely recall something about this breaking in VS2010 with Update 6, as we had completely new VS integration then, and that it was fixed for Composer XE 2013. But I can't find the problem report for this so I could be misremembering. There is no user option for this.

Retired 12/31/2016

I checked with my colleague, who has an identical VS2010/VFC-XE2011 installation and the same updates.The only obvious difference is that I have numerous MS hotfives which she does not have. I'm prepared to accept that this could be sufficient to explain the issue. This will have to wait for our next purchasing cycle. Thanks for your input and quick responses, as always!

Leave a Comment

Please sign in to add a comment. Not a member? Join today