XE 2013 Corrupting Windows environment

XE 2013 Corrupting Windows environment

The "windir" environment variable is getting cleared after runng VS2010 with Fortran. Then I cannot start VS2010 a second time or many other apps because the shortcuts no longer point to them. I have to reboot my PC. I am runng w_fcompxe_2013.1.119 under Windows 7 64 bit.

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I've never seen an issue with WINDIR - the Intel install doesn't touch WINDIR (and I'm not even sure it can be modified.). I have seen issues with PATH, due to a Windows bug that can happen if PATH is extended past a certain length. We made some changes in the 2013 edition to reduce the amount we add to PATH and to try to warn the user if it looks as if it will be too long. I suggest editing PATH and removing any redundant directories (there probably will be some.)

Retired 12/31/2016

I have 2011, 2012, and 2013 compilers all installed. The Fortran parts are all at the start of the PATH. What parts can I remove? I only develope inside Visual Studio, not command line.
Here are the Fotran parts only, the whole path is 2130 characters:
C:\Program Files (x86)\Intel\Composer XE 2011 SP1.344\redist\intel64\mkl;
C:\Program Files (x86)\Intel\Composer XE 2011 SP1.344\redist\ia32\mkl;
C:\Program Files (x86)\Intel\ComposerXE-2011\redist\intel64\mkl;
C:\Program Files (x86)\Intel\ComposerXE-2011\redist\ia32\mkl;
C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\intel64\mkl;
C:\Program Files (x86)\Intel\Composer XE 2011 SP1\redist\ia32\mkl;

You can replace all of that with these:


If you use MKL and want its DLLs in PATH, you should add:


Retired 12/31/2016

That fixed the WINDIR problem thanks.

Glad to hear it. I realized that I made an error in the MKL paths in the above reply and have now corrected it.

Retired 12/31/2016

Trimming the path has caused another problem. VS2010 is now unable to correctly select the compler version. I have 4 versions installed but it always calls and I can no longer use 13. I have mentioned this in support ID: 687890.

Sorry, strike that last comment, I was setting the compiler version for 32 bit and compiling for 64 bit. I must get used to having settings for both platforms. It would be more useful to have solution settings for complier version as it would make supporting old software much simpler. It is currently quite awkward to use since you need to remember to select the compiler version every time you load a solution. And now twice per solution!

The Tools > Options settings are global for that version of VS and not project-specific.

Retired 12/31/2016

Yes I realise they are global settings. That is a problem for me since I need the settings to be solution specific. Having two sets of global settings is now twice as bad as in VS2008 where only have one. I wonder how many people would prefer solution specific settings. Would it be hard to develop this ?

This behavior has not changed since VS2008 - in fact, it has been this way ever since we added the version selection option. I will file a feature request for the ability to set the version per-project (not sure if it can be per-solution - maybe.)

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today