error #5082: Syntax error, found INTEGER_CONSTANT

error #5082: Syntax error, found INTEGER_CONSTANT

I am trying to recompile an old Fortran 77 fixed format program.  There are revision date codes in columns 73 to 80 that are generating the error message below.  I have gone into Project | program Properties | Fortran | Language  and tried **ALL**  combinations of Source File Format and Fixed Form Line Length settings to no avail.  I have changed the extensions from *.for to *.f and still no solution.  I have looked online but did not find a solution.  Here is a sample code snippet and the resultant error messages:

CC

      dimension vmx50(50,4),imxdt(50,4),vmxxx(50,4),vmxyy(50,4),        110198

     *          nmx50(4),mspac(2000),vmxhi(20000),jmxdt(20000),         110198

     *          vxbuf(128),ixbuf(128),ifnxh(4)

CC

1>Compiling with Intel(R) Visual Fortran Compiler XE 13.0.1.119 [IA-32]...

1>C:\OBODM\OBNU\ROUTA.f(22): error #5082: Syntax error, found INTEGER_CONSTANT '110198' when expecting one of: <IDENTIFIER>

Using:

Microsoft Visual Studio 2010

Version 10.0.30319.1 RTMRel

Microsoft .NET Framework

Version 4.0.30319 RTMRel

PS I tried to change the fonts above to Courier New and others but the transfer from Word to here would not allow anything other than Calibri.  Suggestions would be appreciated. 

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

No doubt you've looked at the options summary relating to this question. The default invoked for either .f or .for should be /fixed /extend-source:72, and any text beyond column 72 would be ignored. If you have somehow ended up with /extend-source:80 (or 132) or /free (or the older versions of those), you will have trouble with sequence numbers or revision dates in that part of the data field.
I recognize the possibility that the options don't work as documented, but that would be a bug.
I think I still have awk scripts to remove those numbers (yes, they work with Windows gawk).

Thanks for the quick feedback. I just looked at the Compiler section and this is how it read:

/nologo /debug:full /Od /fixed /warn:interfaces /module:"Debug\\" /object:"Debug\\" /Fd"Debug\vc100.pdb" /traceback /check:bounds /check:stack /libs:static /threads /dbglibs /c

This is with the Fixed Format and 72 character line set in the Language section of the Properties.

I could GAWK it but then I would lose the change dates that are keyed in the source code and other documentation. I think that this is a bug. Do you know if Intel reads these problems and escalates them to bug status or do we have to proactively report this as a bug?

I took the three lines of code above, added a "Program xxx" before and "End" after the lines, and ran the compiler with your options. The Windows compiler13.0.1.119 did not display any error messages. If there is a bug as you say, you have yet to post source code that really triggers the bug.

I am having the same problem. I started with an existing file, with stuff in column 73 on many lines. Got same error when trying to compile. I went to one line that was triggering the error, deleted the character in column 73, error for that line went away when I compiled. I typed the character back into column 73 on that line, and the character showed up in green (visual studio now sees it as a comment). And sure enough, when I compiled again, the compiler had no problems with that line. I got 40 files, 50000 lines of code, and 6 different versions of this program. I don't want to have to manually do this...

Hello MECEJ4,

I followed your suggestion but for the whole subroutine. It did **not** retrigger that error message. I had looked for horizontal tabs and did not find any. I added a few more subroutines and the error reappeared in the original subroutine. I modified the source codes so that there are no warning or remark messages; only the #5082 messages. Only about 6 subroutines were processed before the compiler exited. I think I will compile each subroutine outside the IDE. Do you have any suggestions that might be better? If interested, the source code is available on line for download.

Quote:

Peter Eckhoff wrote:

Hello MECEJ4,

If interested, the source code is available on line for download.


URL, please?

Hello Steve,

I tried your suggestion and it did not work when the "sequence number" was on the same line as a continuation line or a If Then line. There was no problem if it was part of a Comment line. With the IF then line, the number was green with a gray background but the compiler still flagged it. With the others, the number was still black with no gray background. Deleting and retyping the number made no difference. However, when I did what MECEJ4 suggested as a stand alone program, the problem with that set of sequence numbers went away. When it was brought back in as a subroutine, the problem reoccurred. This is old code from the late 80's early 90's. I think I will manually compile each subroutine to see if the problem is with the code or an effect from the IDE/compiler interaction. Hope you have a good weekend and thanks for your input. It was much appreciated.

Try turning off /warn:interfaces. We've seen a bug parsing fixed-form source in some cases where that is enabled.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today