Debugging in Composer XE 2013

Debugging in Composer XE 2013

I have just downloaded this latest version of the Fortran compiler and tried to debug changes to an existing project that was created using Composer XE 2011.  When I tried to look at several variables using the watch list I get the error "Cannot view register variable".  I did not get this error using XE 2011 and it appears that I cannot return to use XE 2011 since XE 2013 converted the project information that makes it inaccessible to XE 2011.  I suspect that there are some project settings that need to be changed but I cannot figure out which should be changed.  I am running using the "Debug / WIn 32" option and the compiler directives are the following:

/nologo /debug:full /O2 /extend_source:132 /Qdiag-error-limit:500 /debug-parameters:all /warn:interfaces /real_size:64 /module:"Debug\\" /object:"Debug\\" /Fd"Debug\vc100.pdb" /traceback /check:bounds /libs:static /threads /dbglibs /c

What can I do to enable the watch list?

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Whoops! On review I noticed that the optimization level was set to 02. When I changed this to 0d, the watch window worked normally. Problem resolved!

Note the original message is not an "error" it means that the compiler has optimised the code such that the value of the variable is being held in a register and not in memory.
It is usual when debugging to turn optimisation off.

However in debug mode you can view the registers (Debug -> Windows -> Registers) so if you know which one is being used for your data then you can view it.

Les

Leave a Comment

Please sign in to add a comment. Not a member? Join today