LINK error-cannot open oleaut32.lib

LINK error-cannot open oleaut32.lib

i have VS2008 along with SDK. i have also installed VF 11.1 with maths kernal library.

while compilling the test application from cmd prompt, it gives error for not able to open oleaut32.lib files. i can locate this file in VS2008 SDK folder.

when i tried to compile the same program through VS interface, it works well. but if i tried to compile using BUILD cmd then it fails.

how to resolve it? moreover, "c----- " is not considered as commented syntex.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

How are you making the compiler available from the command prompt? Are you using the shortcut installed that invokes the compiler .bat file, or are you calling compilervars.bat yourself? compilervars.bat calls the Microsoft vcvars.bat file to set up the LIB path - this is how OLEAUT32.LIB should be found.

What do you mean by "BUILD cmd"?

As for comment syntax, if your file is free-form source (.f90 file type), the comment introducer is ! not c.

Retired 12/31/2016

Thanks Steve,
I got the issue why is this happening but didn't know how to resolve it.
when ever i am logging with local administrator user or with domain administrator, it works well to compile the program using my build.bat file which contains some other include and lib file location. but, if i am logged-in with other user (domain user with administrator rights) it fails or not able to locate VS LIB directory.
I have VS2008 with WindowsServer 2003 Std edition R2.
Pls advice.

You didn't tell me how you make the Visual Studio environment available. Are you using the Intel-provided ifortvars.bat? Please show the output of the full command session.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today