Problem using 64 Bit Fortran with 32/64 C libs

Problem using 64 Bit Fortran with 32/64 C libs

I am using 12.1 .3526.2010

I have had my project working using all 32 bit. And this was fine. I now have changed so that The Fortran program is 64 bit. I am using the 64 bit command line.  When I just make teh same project, I have linker errors with the old 32 bit C libraries, which were made with Visual Studio 2010.  I have copied the notation from the Samples, and I am sure I have the syntax correct, using BIND(c) etc, but I still get the unresolved external errors. I am using CDECL. for the C library.  And I have not added and alias or _ for teh function name in the C library. After all, it was fine in 32 bit mode.


I then tried to use the Intel C++ compiler for the library, and compile in 64 bit. In this case, I now get the Unexpected PDB error, RPC(23).

Any ideas ?


3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You may have some 32-bit objects left over from the failed attempt to use the 32-bit .OBJ files from the C sources with the 64-bit Fortran project.

Try cleaning and rebuilding in pure 64-bit mode.

You can't mix 32- and 64-bit .obj files, regardless of whether they were made by the same or different compilers.
No doubt, you noticed that the error you reported has been known to be provoked by compiling and attempting to link a source file consisting of only comments. You may have to turn off debug symbol generation if you wish to include such files in the build.

Leave a Comment

Please sign in to add a comment. Not a member? Join today