Intellicensecache folder and IRMAGENT.LOG file

Intellicensecache folder and IRMAGENT.LOG file

For years I've been plagued by a folder which appears from time to time when I use the Intel Fortran compiler on Windows. The folder is named Intellicensecache and I've never figured out the conditions under which it appears (though it's obviously something to do with the license for the compiler).

The trouble is that I end up with multiple copies of this folder, all in different places, which pollute my source code tree and sometimes end up getting copied to places where they shouldn't.

Today for the first time I've noticed the appearance of a file named IRMAGENT.LOG which contains a few lines to do with Intel Software Management (I can't remember the exact wording because I'm temporarily off the machine).

Does anyone know how to avoid these folders and files appearing? Are they supposed to be temporary files which are accidentally not being cleaned up for some reason? I wouldn't mind so much if they appeared always in the same place, but as I mentioned they seem to pop up anywhere at random.

Mick Pont

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Yes, this is related to the Intel Software Manager. I know I asked the developers before if there was a way to relocate the files, and they said no, but this is the first I have heard of them going in multiple locations. I will inquire and see what I can find.

Retired 12/31/2016

irmagent appears in my c:\temp since I changed the Windows configuration to put all temp files there. It doesn't clean up automatically, but the same file is re-used each time.

Mick Pont:

By any chance, do you set TEMP to a directory within the current project while building and testing the project?

mecej4: No - I don't touch TEMP - it's defaulting to C:\Users\mick\AppData\Local\Temp

The developers tell me that these files are created in the TEMP folder, so something is apparently changing the definition of TEMP. I was also told that you can delete or rename the files:

\Intel\Intel Software Manager\intelremotemonagent.exe
\Intel\Intel Software Manager\intel64\intelremotemonagent.exe

and reboot.

and this will disable the functionality completely. (You'll still be able to compile.) You may have to repeat the "delete" after updating the compiler.

Retired 12/31/2016

Thanks for the info Steve - perhaps something is messing with TEMP in my build environment, although if it is I
can't see it (our build system is fairly complicated, using a mixture of cygwin/GNU make/shell scripts etc. but I
can't see TEMP being set anywhere).

Also, I can't locate a file named intelremotemonagent.exe anywhere on my machine. I'm using
Intel(R) Visual Fortran Intel(R) 64 Compiler XE for applications running on
Intel(R) 64, Version Build 20121008

My machine does have a folder named c:\Intel but all it contains is another folder named Logs
which contains files like IntelControlCenter.log. Otherwise, under "C:\Program Files\Intel" and
"C:\Program Files (x86)\Intel", no executables with the word "agent" as part of their name.

Ugh - the forum ate part of my text. Look in C:\Program Files (x86)\Common Files\Intel\Intel Software Manager

Retired 12/31/2016

It turned out the problem was not with environment variable TEMP, but TMP. And the problem was that I have various batch files which dynamically change TMP to point at different directories, and those were the directories that Intellicensecache was appearing in.

So - in the end the fix was simple - I just changed all my batch files to use a temporary name other than TMP

Thanks for the help.


Thanks for coming back and giving us the resolution.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today